Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006997 [DCSS] Bug Report minor have not tried 2013-05-02 00:46 2014-05-08 04:11
Reporter rebthor View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006997: When a transformation ends, armour is still melded when falling off a wall
Description I'm not 100% sure this is a bug or a feature. I was playing a NaTm in spider form, clinging to a wall when the transformation ended, I fell off an onto an undiscovered bolt trap which killed me.

This is the last few lines of messages when looking at my morgue:
Your transformation has ended.
You fall off the wall. A bolt shoots out and hits you!
You die...

Which would be fine except for the fact that all my armour is still melded. If the transformation had ended, I would expect that the armour would be unmelded as well and my AC would be higher than the 5 AC it was. Again, I'm not sure if this is intended behavior, but it looks like it checked for the damage from the trap while I was still in spider form and only the next turn would my character actually be out of spider form, however that is inconsistent with the messages.

Morgue link is http://dobrazupa.org/morgue/rebthor/morgue-rebthor-20130104-022607.txt [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0026084)
wheals (administrator)
2014-05-08 04:11

Player clinging is gone in trunk; resolving.

- Issue History
Date Modified Username Field Change
2013-05-02 00:46 rebthor New Issue
2014-05-08 04:11 wheals Note Added: 0026084
2014-05-08 04:11 wheals Status new => resolved
2014-05-08 04:11 wheals Fixed in Branch => 0.15 development branch
2014-05-08 04:11 wheals Resolution open => done
2014-05-08 04:11 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker