Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006979 [DCSS] Patches major have not tried 2013-04-28 19:45 2014-02-23 09:52
Reporter st View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0006979: remove vault redefined monsters
Description .
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Purge-many-vault-redefined-monsters.patch [^] (70,458 bytes) 2013-04-28 19:45 [Show Content]

- Relationships

-  Notes
(0022483)
KiloByte (manager)
2013-04-28 20:06

This patch breaks for example the temple of Zin: the angel will speak stuff about TSO instead.
(0022484)
KiloByte (manager)
2013-04-28 20:10

While I agree with removing vaults that do cause problems, most of this patch seems to axe one-off monsters left and right for no gain. What's wrong with rare monsters that behave well (ie, no buggy corpses, balance issues, spoily vauly problems, etc)?
(0022485)
st (reporter)
2013-04-28 20:44

Standards of vault design, for which we currently have almost none.
(0022490)
Claws (developer)
2013-04-28 23:30

There was a ##crawl-dev discussion on this patch that went to a lot of differing places, and for now I'd like to outline the different issues.

 - a) Are vault monsters inherently bad?
 - b) If not so, should renames be solely based on mechanical differences rather than flavour?
 - c) Are statues, redefined vault monsters or not, bad monsters?

The majority of this patch says no to the first two, because as st states and as can be seen throughout the patch the point is about removing bad vaults, bad uses of vault monsters, bad vault monsters. I have to admit that I'd prefer vaults to avoid resorting to one-off mechanics or interface burdens when they have minimal value or interest, because of the lack of standards letting in more and more vaults of questionable design as well as keeping around older vaults also questionable design. Crawl isn't supposed to be a game for role-playing, and inconsistent, random uses of flavour with many issues on their own don't fit into this as a whole especially when as ubiquitous as this patch shows; vaults as arranged pieces of the many things already in crawl as structures in and of themselves are the standard kept for vaults not defining their own content. Some vault monsters could certainly be made into regular monsters to let regular random generation assess their worth instead of just vaults, but I don't mind this patch's open purge.

On c) I have to admit that I hate immobiles in general because of the tedious hit-and-run tactics they openly promote for minimum danger and the way they remove the actually interesting part of crawl fights, which is player and monster movement as relates to terrain. It doesn't help that a lot of given uses themselves are mechanically highly questionable - orange crystal statues either kill, are left alone, or are instantly killed, and archer statues inevitably run out of arrows. Held to above standards and complaints I would say it's reasonable to cut them, and less hacked-together uses are still allowed for future submission.

Notable examples of "good" versus "bad" uses on vault monsters: sickly sirens and malarious mermaids aren't touched, and an IOOD statue in a very open space was cut while IOOD statues in a more confined corridor with corners that allows careful response was kept. Portals are also untouched on standards of actually being explicitly and purposefully separate from the main game, compared to vault monsters interrupting regular play.

...also! I would love to have something resembling a coherent bunch of statements on what makes a vault good or bad but it seems very difficult to do this and there is little cohesion on this so apparently letting in and out patches from the more experienced vaultmakers is the main thing to do. It shouldn't be the only thing done, of course.
(0022492)
infiniplex (reporter)
2013-04-29 00:10

Personally, I found the hungry kobolds one of the most memorable things in the game. It was somewhat strange that they were in an underground forest clearing, but given the number of other underground forests, I was willing to accept it. Removing the flavour text just seems to make it harder to understand what is happening in it.

+1 to statements in good/bad vault design.
(0022493)
dpeg (administrator)
2013-04-29 00:12

I haven't been around during the ##crawl-dev discussions, sorry about that.
This is a matter which does deserve talk and thought; if things become unwieldy over here, I suggest we take it to emails (among everyone who is interested, or c-r-d).

Claws certainly asks the right questions.

On cosmetic adjectives for monsters (this is Claws' b): Personally, I don't care too much. Cosmetic adjectives allow humour to slip into the game (which is always problematic, but I generally support any attempts -- we can always remove, but overall there is a tendency to strip down everything to the pure, grim core). There is an obvious drawback: overhead with descriptions (more work when taking translations into account), and potential confusion with actually meaningful adjectives (like in sickly sirens). So I am fine to agree to disqualify purely cosmetic adjectives. As Claws says, those are probably alright in portal vaults.

On vault monsters as such (Claws' a), I think we agree there is potential for them. Apart from flavour (ideally left to portal vaults, I also agree), special spellsets etc. can certainly provide good gameplay.

Immobiles (Claws' c) are indeed problematic, as are slow monsters in general. I like oklobs for very personal reasons, and I think statues can be used meaningfully (a very memorable game had a statue protect an early branch entry) but it is true that there probably isn't much to gain from lots of hand-made immobile monsters. As always, there may be special circumstances (e.g. an entry to a timed Bailey entry protected by archer statues is not so bad: you cannot slowly duke it out there) and we should be aware of that.

Summary: I support the patch. While I don't agree with every single decision in there, I think the value of someone going through the files and applying one uniform standard is worth it.

We should, before or after applying the patch, agree on design statements for vaults. I have written quite some vault-related documentation back in the day; so I feel competent enough to chime in. I have never used adjectives in all my vaults, however, and only done very little with Vaults in the recent past anyhow, so I wouldn't like to write vault design specs on my own. If someone reading this feels like it, send me a mail and we can come up with something to present to c-r-d.

By the way, many thanks for your work: reviewing and actually purging vaults is labourious and very welcome!
(0022510)
MarvinPA (developer)
2013-04-30 20:11

Pushed! Also: "Left glowing angels as-is for now to avoid breaking their speech - Zin angels could be made into real monsters or monster speech could be made to take the monster's god into account somehow to fix them."
(0022515)
KiloByte (manager)
2013-04-30 20:48

Er? Why in the blazes would you even consider applying this patch, let alone push it? A part of it is warranted, sure.

A good part of the rest deserves to be called vandalism rather than development, though.

Why won't we delete the whole dat/des/ directory then? C++ layouts might be enough!
(0022516)
KiloByte (manager)
2013-04-30 20:50

Seriously, it'd be faster to revert then decide what to delete, than to re-add stuff that should stay.
(0022517)
KiloByte (manager)
2013-04-30 20:51

"glowing angel" is actually one that has no reason to use a custom name. It did need one in the past, but "dbname:" can be used for custom speech/description now.
(0022609)
KiloByte (manager)
2013-05-09 20:31

Looks like this issue is pretty contentious, and leads to quite strong heat on IRC. (I'd like to apologize for at least some of my angry words.)

Somehow interesting that the vault with strongest, pretty much unanimous support for bringing back is goddamned_bats, something undeniably silly (especially fruity and dwarf mountain bats). That vault is all flavour with no action.

Yet flavour itself shouldn't be dismissed, it's a good part of what makes the game fun.

And most important, no reason was stated other than "renames are bad". Even that was applied quite inconsistently, leaving some dubious renames while removing others, in one case even with an identical name ("spriggan baker"). In the vault that was left alone, I'd say he has no reason to stay: there's no reference other than the vault's name, something that's not visible to the player. In the other case, though, something that was meant to show a bustling town, was reduced to a bunch of spriggans in rectangular rooms. There's no likely player confusion: a baker or a shepherd is not expected to have special powers, and this is a place where such monsters look naturally. This is not the case for a random room on D:8.

Or, if you see a bunch of demon and a neutral human behind glass, the player just thinks the situation is a bit silly, somewhat confused, might try poking around. A single adjective can immediately make it obvious what's going on, and add flavour.

I don't deny a good part of monsters this patch removes is indeed superfluous, like, say, all those odd fruiting trees. That clean-up is good.

Yet it went way too far, purging monsters just because of which file they were defined in. I'd say one-off monsters should be removed only if they bring confusion, or have no obvious reason for renaming.

Thus, should we start with a list of reasons, or with per-vault discussions?
(0022615)
infiniplex (reporter)
2013-05-09 21:07

Reasons. Otherwise per-vault discussions will just get bogged down with people using different standards unable to reach common ground.
(0022616)
Claws (developer)
2013-05-09 21:32

Subjective interpretation for a vault to speak for itself is one of the weakest arguments possible. The spriggan forest is still a lot of a specific rare monsters in buildings inside a forest suddenly inside D, while almost nowhere else (butterflies) are there monsters dedicated to non-combat roles; a neutral locked-away human surrounded by demons already looks like a prisoner even if it doesn't have "sacrificial" before its name, and such a name vaguely suggests something happening when it's just a human left in a cage.

Flavour isn't lost when a single vault - a single rare level chunk - doesn't get to place a distinct monster. Regular monsters - and all of the things involved in them, in mechanical threat and description and use and context - can still have and express flavour, and we could certainly change old descriptors to be stronger in theme, or add new regular monsters focused on such themes.

The main opposing argument has been brought up in this mantis ticket and on ##crawl-dev: there are issues of interface burden and spoilers inherent in having _cosmetic_ renames when there are important information provided by other adjectives (young spriggan druid, sickly siren) and by descriptors in regular monsters _in_and_of_themselves_ (slime creature sizes, monster classes).

I do not have many comments on the full degree of criteria st_ took in passing through the .des files. More certainly can and should be done after this patch from either side, but what is to be done in general isn't agreed upon.

I tried to start a brainstorming document focusing on the principles behind the use and mis-use of controversial gimmicks but got little input from ##crawl-dev, and am waiting for the presence of other prolific level designers (st_, evilmike, dpeg) for comment as well as sorting out my own thoughts. https://docs.google.com/document/d/1eezu_YRixgNN2IuzSnWNWoPwZjs_YuXmdFvVzQWWGlk/ [^]

Certainly more thorough discussion could take place by bringing up select arguments, but not much will be done if there's nothing but strawmen bandied about.
(0025376)
MarvinPA (developer)
2014-02-23 09:52

Resolving, this has been in for a while.

- Issue History
Date Modified Username Field Change
2013-04-28 19:45 st New Issue
2013-04-28 19:45 st File Added: 0001-Purge-many-vault-redefined-monsters.patch
2013-04-28 20:06 KiloByte Note Added: 0022483
2013-04-28 20:10 KiloByte Note Added: 0022484
2013-04-28 20:44 st Note Added: 0022485
2013-04-28 23:30 Claws Note Added: 0022490
2013-04-29 00:10 infiniplex Note Added: 0022492
2013-04-29 00:12 dpeg Note Added: 0022493
2013-04-30 20:11 MarvinPA Note Added: 0022510
2013-04-30 20:48 KiloByte Note Added: 0022515
2013-04-30 20:50 KiloByte Note Added: 0022516
2013-04-30 20:51 KiloByte Note Added: 0022517
2013-05-09 20:31 KiloByte Note Added: 0022609
2013-05-09 21:07 infiniplex Note Added: 0022615
2013-05-09 21:32 Claws Note Added: 0022616
2014-02-23 09:52 MarvinPA Note Added: 0025376
2014-02-23 09:52 MarvinPA Status new => resolved
2014-02-23 09:52 MarvinPA Fixed in Branch => 0.14 development branch
2014-02-23 09:52 MarvinPA Resolution open => done
2014-02-23 09:52 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker