Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006947 [DCSS] Patches minor N/A 2013-04-22 22:16 2013-04-24 02:01
Reporter cjo View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0006947: New mana shield mutation, revised from 0006932
Description Revised version of new mana shield mutation.
Tier 1: mana shield (same as guardian spirit)
Tier 2: mana regeneration bonus
Tier 3: mana link--at low mana, you regenerate mp in place of hp, and gain drain resistance.

Amounts of drain resistance, mana regeneration bonus, and the amount of damage applied to hp versus mp can all be adjusted to alter the power of these mutations.

(I was planning to make tier 3 be simply mana drain resistance, but that seemed a bit dull. I thought the two attributes (regenerating mp in place of hp, and being resistant to mana drain) went together thematically. However, the preferential mp regeneration can be easily pulled if not wanted.)
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Mana-Shield-mutation-revised.patch [^] (6,506 bytes) 2013-04-22 22:16 [Show Content]

- Relationships
has duplicate 0006932resolvedMedar player content submission: add new "mana shield" mutation. 

-  Notes
(0022390)
Galefury (updater)
2013-04-22 22:40
edited on: 2013-04-22 22:40

When posting updates to an existing patch, it's better to keep it to a single mantis issue if it's still open. I marked the other one as a duplicate and resolved it.

Edit: or at least I tried to, apparently Medar was faster. :)

(0022392)
MarvinPA (developer)
2013-04-23 05:23

I tried this a bit locally and it seems potentially cool, pushing it for testing with a couple of tweaks:
- Made it provide regular guardian spirit so that it shows up on %, no code duplication needed.
- Removed the mana drain resistance, since it's a minor effect and somewhat inconsistent (the patch had it only affect the monster ability, not anti-magic brand attacks, evokable items or god wrath/Zot trap miscasts - and some of those definitely shouldn't be affected either way); also it makes sense for a mana shield to make you more worried about sources of MP drain in the rare places they do occur (also it made the mutation description too long to fit in console :P).
(0022410)
sgrunt (administrator)
2013-04-24 02:01

This has landed, so I'm marking this ticket resolved.

- Issue History
Date Modified Username Field Change
2013-04-22 22:16 cjo New Issue
2013-04-22 22:16 cjo File Added: 0001-Mana-Shield-mutation-revised.patch
2013-04-22 22:33 Medar Relationship added has duplicate 0006932
2013-04-22 22:40 Galefury Note Added: 0022390
2013-04-22 22:40 Galefury Note Edited: 0022390
2013-04-23 05:23 MarvinPA Note Added: 0022392
2013-04-24 02:01 sgrunt Note Added: 0022410
2013-04-24 02:01 sgrunt Assigned To => MarvinPA
2013-04-24 02:01 sgrunt Status new => resolved
2013-04-24 02:01 sgrunt Resolution open => done
2013-04-24 02:01 sgrunt Fixed in Branch => 0.13 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker