Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006928 [DCSS] Bug Report major have not tried 2013-04-17 23:04 2013-05-18 19:47
Reporter HilariousDeathArtist View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0006928: Friendly Cacodemon can cast Confuse on the player
Description I summoned a friendly Cacodemon using Makhleb's Summon Greater Demon ability and it seems that it will attempt to cast Confuse on an enemy when it's line of sight is blocked by the player, thus causing the spell to be cast on the player character.

Additional Information
Tags No tags attached.
Attached Files txt file icon HilariousDeathArtist.txt [^] (28,230 bytes) 2013-04-17 23:04 [Show Content]

- Relationships
related to 0005443resolvedsgrunt hostile gnoll shaman heals player character 

-  Notes
(0022325)
neil (administrator)
2013-04-17 23:35
edited on: 2013-04-17 23:36

This is because confuse is in the "self-enchant" spell slot (spells[2]), which can be chosen as a fallback and if so skips most of the safety checks (including "will that actually hit what I am targetting?").

And cacodemon's slots are more or less full (only the "emergency" slot is free), so just moving spells around won't help. It *might* be possible to put Dig into the self-enchant slot (as a special case, Dig is removed from all slots before we get to this point in the code), but that might have other bad side effects.

Probably cacodemon will need to lose a spell to really solve this problem (I'd recommend Slow, maybe Confuse), unless someone wants to rewrite the monster spell-choosing code to make the self-enchant slot not behave poorly with targetted spells.

(0022693)
sgrunt (administrator)
2013-05-18 19:47

As of 0.13-a0-743-g862d934, spells in the monster self-enchantment slot get the proper spellcasting checks they deserve, so this is an ex-problem.

- Issue History
Date Modified Username Field Change
2013-04-17 23:04 HilariousDeathArtist New Issue
2013-04-17 23:04 HilariousDeathArtist File Added: HilariousDeathArtist.txt
2013-04-17 23:35 neil Note Added: 0022325
2013-04-17 23:36 neil Note Edited: 0022325
2013-05-18 19:45 sgrunt Relationship added related to 0005443
2013-05-18 19:47 sgrunt Note Added: 0022693
2013-05-18 19:47 sgrunt Assigned To => sgrunt
2013-05-18 19:47 sgrunt Status new => resolved
2013-05-18 19:47 sgrunt Resolution open => done
2013-05-18 19:47 sgrunt Fixed in Branch => 0.13 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker