Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006871 [DCSS] Patches minor N/A 2013-04-03 23:40 2014-04-08 17:10
Reporter khalil View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.12 ancient branch
Summary 0006871: Twisted resurection rebalanced
Description One of the threads on GDD said TR was overpowered because you ended up building a huge army, and that the monsters requiring corpses to heal would help.
I went and coded it up.
Additional Information
Tags No tags attached.
Attached Files txt file icon notapatch.txt [^] (5,819 bytes) 2013-04-03 23:40 [Show Content]
txt file icon notapatchv2.txt [^] (5,977 bytes) 2013-04-04 21:05 [Show Content]
? file icon 0001-Make-aboms-from-twisted-resurrection-heal-from-corps.patch [^] (3,000 bytes) 2013-04-04 23:11 [Show Content]

- Relationships

-  Notes
(0022133)
dolorous (updater)
2013-04-04 20:57

I've turned it into a patch against current trunk; thanks.

I made one code tweak: In your original code, hp_gain is set to 0 when merging with a large abomination, which means that the code in that chunk that adds hp_gain to hp and mhp is redundant, so I removed that code. (Or was hp_gain supposed to be set to something else there?)
(0022134)
khalil (reporter)
2013-04-04 21:04

No, I was just confused as to what was happening. There's actually a few problems with it, among other things large abominations don't stop absorbing crawlers when fully healed. Here's a fixed version.
(0022136)
dolorous (updater)
2013-04-04 23:11

Thanks; I've made a second trunk patch from it (labeled version 2 in the commit message).

I still needed to tweak a few bits. willmerge is no longer needed (if a large abomination is fully healed, _do_merge_crawlies() can just return false), and hp and mhp need to be initialized as merge_to->hit points and merge_to->max_hit_points before doing any healing (so that the large abomination doesn't destroy itself by setting its HP to 0).
(0022139)
khalil (reporter)
2013-04-05 01:00

There's a check to make sure that if healing would put hp over mhp, it just sets one to be equal to the other.
else if (merge_to->max_hit_points <= merge_to->hit_points + merge_to->max_hit_points/10){hp = mhp;}
Wouldn't that do the trick?
(0022140)
dolorous (updater)
2013-04-05 01:59
edited on: 2013-04-05 02:01

No, because hp and mhp are both initialized to 0 and aren't assigned anything else by that point.

else if (merge_to->max_hit_points <= merge_to->hit_points + merge_to->max_hit_points/10){hp = mhp;}

needs to be

else if (merge_to->max_hit_points <= merge_to->hit_points + merge_to->max_hit_points/10){mhp = merge_to->max_hit_points;
hp = merge_to->hit_points;}

before modifying hp or mhp at all, as it is in the new version of the patch.

(0022141)
khalil (reporter)
2013-04-05 02:11

Oh. Sorry, I'm a bit new to this.
(0022142)
dolorous (updater)
2013-04-05 02:14

No problem.
(0024696)
neil (administrator)
2013-12-11 18:09

In trunk (0.14-a0-1419-g2e2cdf5), thanks. We'll need to look into other uses of abominations: Abyss is probably fine and MarvinPA says XXX is probably fine, but vaults that use aboms like Cigotuvi's wizlab might need tweaking to deal with the no-regen aspect.

Leaving this bug open since I don't think this is the only TR balance change that will be needed.
(0025768)
MarvinPA (developer)
2014-04-03 16:29

Resolving this since the changes have been in for a while, if more changes are needed that can probably be discussed elsewhere at this point.
(0025806)
khalil (reporter)
2014-04-08 17:10

Agreed. Closing.

- Issue History
Date Modified Username Field Change
2013-04-03 23:40 khalil New Issue
2013-04-03 23:40 khalil File Added: notapatch.txt
2013-04-04 20:57 dolorous Note Added: 0022133
2013-04-04 20:58 dolorous File Added: 0001-Make-aboms-from-twisted-resurrection-heal-from-corps.patch
2013-04-04 21:04 khalil Note Added: 0022134
2013-04-04 21:05 khalil File Added: notapatchv2.txt
2013-04-04 23:11 dolorous Note Added: 0022136
2013-04-04 23:11 dolorous File Deleted: 0001-Make-aboms-from-twisted-resurrection-heal-from-corps.patch
2013-04-04 23:11 dolorous File Added: 0001-Make-aboms-from-twisted-resurrection-heal-from-corps.patch
2013-04-05 01:00 khalil Note Added: 0022139
2013-04-05 01:59 dolorous Note Added: 0022140
2013-04-05 02:01 dolorous Note Edited: 0022140
2013-04-05 02:11 khalil Note Added: 0022141
2013-04-05 02:14 dolorous Note Added: 0022142
2013-12-11 18:09 neil Note Added: 0024696
2013-12-11 18:09 neil Status new => confirmed
2014-04-03 16:29 MarvinPA Note Added: 0025768
2014-04-03 16:29 MarvinPA Status confirmed => resolved
2014-04-03 16:29 MarvinPA Fixed in Branch => 0.14 development branch
2014-04-03 16:29 MarvinPA Resolution open => done
2014-04-03 16:29 MarvinPA Assigned To => MarvinPA
2014-04-08 17:10 khalil Note Added: 0025806
2014-04-08 17:10 khalil Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker