Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006857 [DCSS] Bug Report crash always 2013-04-02 13:28 2013-04-03 07:28
Reporter madreisz View Status public  
Assigned To DracoOmega
Priority normal Resolution done  
Status resolved   Product Branch 0.13 ancient branch
Summary 0006857: Crash when trying to read scroll of summoning in vaults:5
Description The game crashes when I try to read a scroll of summoning in vaults:5, I'm not sure if it happens elsewhere. Earlier in the same game it worked fine in the regular dungeon.

Backed up save: http://dobrazupa.org/saves/madreisz-crawl-git-e904e0d0eb-130402-1124.tar.bz2 [^]

Crash log: http://dobrazupa.org/morgue/madreisz/crash-madreisz-20130402-112157.txt [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0022090)
KiloByte (manager)
2013-04-02 13:37

Happens if you summon a ghost_demon monster under TSO.
(0022122)
DracoOmega (developer)
2013-04-03 07:28

More specifically it happened if you summoned a dancing weapon under a good god (since the ghost_demon structure wasn't initially for these upon creation, unlike all other types of ghost_demons)

In any case, it is fixed in 0.13-a0-128-g70a4f2e

- Issue History
Date Modified Username Field Change
2013-04-02 13:28 madreisz New Issue
2013-04-02 13:37 KiloByte Note Added: 0022090
2013-04-03 07:28 DracoOmega Note Added: 0022122
2013-04-03 07:28 DracoOmega Status new => resolved
2013-04-03 07:28 DracoOmega Fixed in Branch => 0.13 development branch
2013-04-03 07:28 DracoOmega Resolution open => done
2013-04-03 07:28 DracoOmega Assigned To => DracoOmega


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker