Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006851 [DCSS] Bug Report minor always 2013-04-01 07:29 2015-12-06 22:18
Reporter magicpoints View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006851: When a TSO worshipper spits poison at a hostile creature, they do not receive a warning
Description When a player who has the Spit Poison mutation while worshiping The Shining One spits at a hostile creature, the game does not ask for confirmation. This act will place the player under penance without a warning, unlike other sources of poison damage.

This bug mostly affects Nagas due to their innate Spit Poison, but could affect a character of any other race who gains the mutation later. I noticed this playing as 'magicpoints' on CSZO, when playing as a NaPr of TSO.

This bug does not apply if a player spits poison at a non-hostile creature, as they will get a prompt for attacking a non-hostile as normal. This bug also does not apply to a Green Draconian's breath, as their breath is instead noxious fumes and not damaging poison.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
has duplicate 0010009closedwheals TSO does not give warning before using Poison Spit 

-  Notes
(0025008)
magicpoints (reporter)
2014-01-17 01:54

I'm still getting this in 0.14-a.
(0029949)
wheals (administrator)
2015-12-06 22:18

Fixed in https://github.com/crawl/crawl/commit/31c9eb47e00f, [^] thanks!

- Issue History
Date Modified Username Field Change
2013-04-01 07:29 magicpoints New Issue
2014-01-17 01:54 magicpoints Note Added: 0025008
2015-11-23 01:23 wheals Relationship added has duplicate 0010009
2015-12-06 22:18 wheals Note Added: 0029949
2015-12-06 22:18 wheals Status new => resolved
2015-12-06 22:18 wheals Fixed in Branch => 0.18 development branch
2015-12-06 22:18 wheals Resolution open => done
2015-12-06 22:18 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker