Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006722 [DCSS] Bug Report major always 2013-03-02 10:53 2015-02-20 21:40
Reporter Zaraka View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0006722: Cannot use fullscreen on dual monitors
Description When fullscreen is set to true in init.txt
DCSS try to create window for both screen.
I have two screen 1366*768 and 1440*990.
DCSS throws "Failed to set video mode: No video mode large enough for 2808x900"
one screen fullscreen or no fullscreen two screens works fine.
Fedora 17/3.7.9
Additional Information
Tags No tags attached.
Attached Files jpg file icon dual_crawl.jpg [^] (129,381 bytes) 2013-03-12 13:59

- Relationships
related to 0003668resolvedneil Crawl Tiles spans across dual monitors (vertically) (Linux Mint 10, Gnome, Nvidia Twinview) 
child of 0001004closed [Tiles] On-the fly window resizing 

-  Notes
(0021227)
AriaB (reporter)
2013-03-02 12:26

Fullscreen works fine for me, running Win7 on three monitors all 1920x1080.
(0021380)
KiloByte (manager)
2013-03-12 14:06

AriaB: all of your monitors are of the same size, the submitter has them different.

I also see it tries to span both monitors, like on the photo I attached.
(0021571)
neil (administrator)
2013-03-16 18:04

While KiloByte's complaint may be a duplicate of 0003668, that is not the same as the submitter's problem because it sounds like they *want* it to span both screens, but it throws an error instead. Changing relationship from "Duplicate" to "Related".
(0021583)
KiloByte (manager)
2013-03-16 18:48

Actually, as I read it, the submitter doesn't even want that, just regular fullscreen. Which fails because the first monitor is not as tall as the second, and Crawl looks at the total size reported by the operating system, which is a bounding rectangle for all screens.
(0028540)
neil (administrator)
2015-02-20 21:40

Anyway, this should be fixed with the SDL2 port, since "fullscreen" uses just one screen. Thanks!

- Issue History
Date Modified Username Field Change
2013-03-02 10:53 Zaraka New Issue
2013-03-02 12:26 AriaB Note Added: 0021227
2013-03-12 13:59 KiloByte File Added: dual_crawl.jpg
2013-03-12 14:06 KiloByte Note Added: 0021380
2013-03-15 04:42 mumra Relationship added duplicate of 0003668
2013-03-15 05:27 mumra Relationship added child of 0001004
2013-03-16 18:04 neil Note Added: 0021571
2013-03-16 18:04 neil Relationship deleted 0003668
2013-03-16 18:05 neil Relationship added related to 0003668
2013-03-16 18:48 KiloByte Note Added: 0021583
2015-02-20 21:40 neil Note Added: 0028540
2015-02-20 21:40 neil Status new => resolved
2015-02-20 21:40 neil Fixed in Branch => 0.16 development branch
2015-02-20 21:40 neil Resolution open => done
2015-02-20 21:40 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker