Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006667 [DCSS] Upload: Maps and Vaults feature N/A 2013-02-20 00:01 2016-06-15 07:18
Reporter infiniplex View Status public  
Assigned To Claws
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006667: New wizlab: Nikola's Generator
Description Nikola's Generator: A wizlab based on metal and electricity

The map design is two steam turbines (containing diamond obelisks) and channels of water to power them. There are also a few rooms around the edge. Nikola himself is not present (because he's in the dungeon).

The defining feature of this wizlab is that Ball Lightning keeps randomly appearing. It is summoned with dur:1, so it yields no XP and disappears again after a few moves. This makes resting very dangerous.

I have collected everything into one text file with notes on where it goes.

One strange thing I noticed while making this: Metal walls ground electricity, but iron grates do not. It seems a bit inconsistent.
Additional Information
Tags No tags attached.
Attached Files ? file icon wizlab_nikola_all.des [^] (8,564 bytes) 2013-02-20 00:01 [Show Content]

- Relationships

-  Notes
(0021088)
Claws (developer)
2013-02-20 00:24

The ball lightning effects are more interrupting then dangerous because of their confused nature and often will spawn behind grates rather than be directly dangerous, which makes them more an annoyance than a threat. (Multiple ball lightnings might mean more, or changing ball lightning behaviour itself.)

Most of the enemies are in numerous numbers and simply too weak for the corresponding depth (iron devil, sixfirhy, electric eel, lightning spire) even without rElec, which altogether makes the wizlab mostly about the draconians and an electric golem weaker than the one used in wizlab_doroklohe (both by HD and no bolt-bouncing, though doroklohe is a death trap). This does match with some other wizlabs (_eringya, _wucad_mu) but both of those aren't held in too high regard for their threats involved either.

Personally not liking it, sorry.
(0021089)
chris (updater)
2013-02-20 00:47

Posted an adapted patch at http://bpaste.net/show/kbx4lJZljgjeZsQ8obIU/ [^] ("raw" for the format-patch and the changes i did) to make testing this a bit easier.

Does not care about authorship at all, so if somebody plans to push this, please fix before doing so.
(0021102)
infiniplex (reporter)
2013-02-20 19:27

The big question, I guess, is if this can be made to work. If not, there is really no point fiddling with it. Claws raises two good points that both need to be dealt with.

I had been hoping to make the ball lightning spawn only if there was a threat nearby. Does anyone know of a LUA function to detect if there are nearby monsters? Or detect tension? Or, for that matter, determine if there is line-of-effect to an cell from the player? I will probably also ask on IRC later.

I had weakened the electric golem because I thought a monster that is scary in Zot would be to dangerous for characters entering the deeper part of the dungeon. I could increase the HD to 12. I tried (and possibly failed) to balance this against wizlab_zonguldrok.

I will remove the electric eels: they don't really make sense. I would like the sixfirhys for thematic reasons (they are here to feed on the electrical energy), but I am happy to replace the iron devils and lightning spires. I will try it with iron elementals and the occasional storm dragon. I might leave iron devils on the random monster list to avoid making shadow creatures too good. I might put in some sort of spellcaster statue, but I will have to think about it.
(0021105)
infiniplex (reporter)
2013-02-21 05:56

I now have solutions to the stuff I mentioned above (thanks chris), but I heard on IRC that the behaviour of iron grates may be changing. I am going to wait to see what happens with that before doing more with this.
(0021106)
Galefury (updater)
2013-02-21 16:12

It already did: gitorious.org/crawl/crawl/commit/e51569814

I don't know what you heard on IRC and when you heard it, but according to the commit log iron grates currently ground electricity.
(0021109)
infiniplex (reporter)
2013-02-21 21:10

I think they may be changing again.

From the 20-Feb-2013 IRC log:
22:31:10 <kilobyte> infiniplex: it looks like there's a consensus to make all spells and ranged attacks work through grates
22:31:24 <kilobyte> because current state is mostly unmanageable: too many special cases
(0030629)
Claws (developer)
2016-06-13 04:20

With neither grates nor ball lightning effects every really handled, with infiniplex having drifted off in the past year, and with me never being fond of Nikola's invocation here, I converted the above vault into a large Zot vault instead of a wizlab in 9200b3b0ab so the above still gets some use.

If somebody is really dedicated to this all, they can re-open this issue, take the changes I made in that commit, and pair them with an improved ball lightning effect plus some nerfs to make it fit as a wizlab. I'm not convinced that that is a great idea anyway.
(0030645)
infiniplex (reporter)
2016-06-15 07:18

I approve of Zot-ifying this. It didn't turn out nearly as well as I had imagined it, and I was actually assuming that it had been dropped as "too bad to go in". This way it will be good for something, which is one up on before.

- Issue History
Date Modified Username Field Change
2013-02-20 00:01 infiniplex New Issue
2013-02-20 00:01 infiniplex File Added: wizlab_nikola_all.des
2013-02-20 00:24 Claws Note Added: 0021088
2013-02-20 00:47 chris Note Added: 0021089
2013-02-20 19:27 infiniplex Note Added: 0021102
2013-02-21 05:56 infiniplex Note Added: 0021105
2013-02-21 16:12 Galefury Note Added: 0021106
2013-02-21 21:10 infiniplex Note Added: 0021109
2016-06-13 04:20 Claws Note Added: 0030629
2016-06-13 04:20 Claws Status new => resolved
2016-06-13 04:20 Claws Fixed in Branch => 0.19 development branch
2016-06-13 04:20 Claws Resolution open => done
2016-06-13 04:20 Claws Assigned To => Claws
2016-06-15 07:18 infiniplex Note Added: 0030645


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker