Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006656 [DCSS] Upload: Graphics feature N/A 2013-02-17 06:13 2013-06-15 23:53
Reporter Bloax View Status public  
Assigned To KiloByte
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006656: Doom Cacodemon cameo?
Description I decided to mess around with downscaling a cacodemon to 32x32 and tweak it around a bit.
And suddenly I ended up with something quite usable.

So, anyone up for a cacodemon cameo replacement for the cacodemon?
(I don't even think the monster itself needs any changes. o_O)
((Maybe more health, but otherwise it's just a simple tileswap.))
Additional Information
Tags No tags attached.
Attached Files png file icon Tomato4.png [^] (973 bytes) 2013-02-17 06:13


png file icon Tomato5.png [^] (957 bytes) 2013-02-17 23:26


png file icon Tomato6.png [^] (950 bytes) 2013-02-19 00:41


png file icon Tomato7.png [^] (999 bytes) 2013-02-19 03:14


png file icon Tomato8.png [^] (1,266 bytes) 2013-02-19 20:32

- Relationships

-  Notes
(0021052)
neil (administrator)
2013-02-17 06:27

I'm pretty sure that the Doom assets are still under copyright, and it would be hard to not call this a derivative work.

If you were to draw something similar-looking (but not too similar) rather than downscaling and editing an existing image, that could work.
(0021053)
Bloax (reporter)
2013-02-17 06:49

gosh i love copyright it is the bestest let's make it infinite
(0021054)
Bloax (reporter)
2013-02-17 07:14
edited on: 2013-02-17 07:22

Added a new sprite that I just drew from scratch.
Edit: A bit better.

(0021055)
KiloByte (manager)
2013-02-17 13:23

> gosh i love copyright it is the bestest let's make it infinite

That's the current plan :(
(0021058)
neil (administrator)
2013-02-17 23:31

Bloax: Please pick less offensive filenames in the future. While, yes, the cacodemon does have a very creepy grin, humour involving rape is not acceptable in the Crawl community, particularly not in official resources like Mantis.

Version 3 has been re-uploaded with a different name, but version 2 was unfortunately lost in a renaming accident.
(0021060)
Bloax (reporter)
2013-02-18 00:20

Things happen in irrational anger. Things that violate tomatoes and vocabularies. :p
(0021072)
KiloByte (manager)
2013-02-18 23:30

neil: actually, historically the most prominent forum for Crawl-related talk used to be Something Awful, where references used make TomatoRapist very, very mild in comparison. Thus, I see no reason to be aggressive about words used, at least as long they don't attack a particular person.

Bloax: your tile is nice, although the rim looks quite artificial. What about reducing it somehow? At least dropping pixels that touch non-rim only diagonally, and doing something to the straight lines on the top and right side.
Alternatively, we could use partial transparency on the edge to make it blend it smoother.
(0021073)
Bloax (reporter)
2013-02-19 00:42
edited on: 2013-02-19 03:15

How's this now?
Edit: Some more small structural adjustments in the seventh iteration.

(0021078)
minmay (reporter)
2013-02-19 07:32

It'll go perfectly with the ball lightning from Descent. Just need a new war dog tile...
(0021079)
mumra (developer)
2013-02-19 12:52

Personally I feel this would look a bit strange and out of place if I saw it in a game. I'm not exactly sure if it's the colour scheme or the overall look, but id software's design is sort of "sci-fi/alien/demonic" whereas Crawl is more "fantasy/demonic". I'm not objecting to the idea of _referencing_ Doom but I think it would be a funnier/more interesting reference if the tile was either a) an originally designed fantasy-style demon that happened to share certain properties of Doom's cacos, as in "disembodied floating vaguely spherical weird thing with horns", but completely different colours and style; or b) took the tomato reference far more literally, as in start by drawing a tomato then add features until it _loosely_ resembles a Doom caco. Players would get the joke I think. Anyway that's just me ;)
(0021080)
KiloByte (manager)
2013-02-19 14:30

mumra: is there's anything sci-fi about Doom cacos?
(0021081)
Bloax (reporter)
2013-02-19 15:23
edited on: 2013-02-19 15:24

It's literally just the face of the Astral Dreadnought from D&D except with a "3D" body in the shape of a weird orb kind of thing. :P
So unless that thing is Sci-Fi, then there really isn't. (Unless spitting balls of "plasma" is too "Sci-Fi")

Also, I think the biggest problem is my 'art style" (if you can call it that), because the vast majority of the sprites/tiles are high-contrast/low-color with dithering, and then suddenly you see a high-color/lower-contrast sprite.

If you want an example, then the new Crocodile sprite that I did kind of clashes with other things. (Like, try looking up "Spiny frog" after looking at the crocodile @ the knowledge bots. It clashes pretty hard.)
Though one thing it doesn't clash with is the hell sentinel sprite. (Which is cool.)

(0021082)
KiloByte (manager)
2013-02-19 15:38

I'd say the low-colour thing is caused by:
* one of core contributors (Denzi) using some _ancient_ software that's limited to a fixed 256 colour palette
* folks not knowing the concept of alpha other than 0 and 100%
* most tiles using the autorimmer

I for one _greatly_ prefer nicely antialiased tiles. Especially regular circles look abysmal without antialiasing. Auras, etc, look far better with partial transparency, too.

I wouldn't care much about clashing with such tiles. Especially dithering needs to go -- 256 colour displays are a bad memory from the previous millenium. On the other hand, high contrast is good as small tiles look too flat and hard to discern otherwise, but this doesn't mean one should skip nice gradients.
(0021083)
mumra (developer)
2013-02-19 15:51
edited on: 2013-02-19 15:51

kilobyte: I think it looks more "alien" than "fantasy" so I would call that sci-fi; I agree the distinction is completely arbitrary and down to taste, but you cannot deny that Doom _is_ a sci-fi game...

Separately to that, I think such an obvious cameo would simply look out of place - Crawl often makes cultural references and jokes but when does it ever copy directly; such an obvious ripoff seems a little out of place to me.

Well this is all completely subjective anyway, I just like how Crawl has its own take on things, typically deriving from source mythology rather than popular culture (e.g. I would compare the stance on Tolkienesque dwarves vs. Norse mythology...) - so my suggestion was simply a slightly more subtle or jokey reference rather than an obvious "Doom cacodemon in your face!"

On further reflection there is at least one direct rip-off from modern culture, which is Murray: this makes me think maybe this caco tile could be used for a Caco unique with a backstory about "falling through a rift in time and space from a parallel universe" to explain why it looks different to other cacos... As a unique it could be given Flying status and a conjuration derivative that behaves a little like their plasma balls in Doom (maybe a retiled IOOD with a 1 tile blast radius), without altering the base monster.

(0021084)
KiloByte (manager)
2013-02-19 16:24

Blast radius? Cacodemon projectiles have no area effect in Doom.

As for the original mythology, "cacodemon" is way too broad category, as it means the same as today's "demon" -- the concept of eudemons or regular impartial demons has been eradicated by Christianity. Looking around, I see no prominent other designs for cacodemons -- it either means "evilly-aligned demon in general" (like AD&D 2nd ed), or a close variant of Doom's concept. Thus, since only the latter provides a particular design, I like this tile.
(0021085)
mumra (developer)
2013-02-19 16:56

They had a very small area effect, it wasn't visibly obvious but if one exploded quite near you it still hurt (iirc, same as Baron of Hell's projectile and a couple others... of course it's been a while and maybe I'm misremembering.)

Apparently, id themselves based the cacodemon design on the astral dreadnaught illustation on _this_ D&D cover: http://doomwiki.org/w/index.php?title=File:Beholdercaco.jpg&filetimestamp=20050109022810 [^]

Now to me, that thing looks incredibly evil and scary; way more so than id's variant which I always found a bit too cute like a cheeky demonic sheep, I even felt somewhat sorry for it especially every time I heard that death gurgle. I really like the colour scheme on that D&D cover as well, it just looks awesomely fire-and-brimstoney. If the tile looked more like _that_ I would have no complaints, but certainly you've convinced me that the current version is less inappropriate than I thought ;)
(0021086)
Bloax (reporter)
2013-02-19 20:31

I did get a suggestion to make it more orangey, and well - let me take a try at it.
But the thing is just that dark orange looks pretty bad, and bright orange is hardly distinguishable from bright red.

Point in hand: https://dl.dropbox.com/u/63152810/Tomato8.png [^]
(I actually messed around with the teeth here, SEEMS better, but it's so messy that anyone who'd like to mess with it in the future is going to hate me.)
(0021091)
roctavian (developer)
2013-02-20 12:01

For my part, I do think this looks well-made but I do think it's a bit too overt a reference -- on the other hand, we do have quad damage, so there's some precedent. If this tile were used in a sprint map or something along those lines, I feel like that would be appropriate.
(0021092)
KiloByte (manager)
2013-02-20 14:27

Too overt? Heck, there's been talk of a Doom total conversion, as some people really hate what's happening in DoomRL in the past 2-3 years. Using this tile would avoid troubles with the one monster whose name conflicts :p

More seriously: if too overt references are bad, let's remove all those Greek uniques.
(0021101)
Bloax (reporter)
2013-02-20 19:07
edited on: 2013-02-20 19:08

The sole reason I actually did this is because every time I read "Cacodemon" I can't stop thinking of this thing.

And it doesn't help that I primarily exist over at the Doom community.
Oh, and if there's going to be a DoomRL knockoff somewhere, I wouldn't mind giving a hand. (Though the chances of me stumbling on it myself would be non-existent. :v)

(0021112)
roctavian (developer)
2013-02-22 11:52

Allusion to mythology is one thing, but references to other games can bring us all sorts of places. The flavor of Crawl is diffuse and full of weirdness like pizza and death yaks, and I think that's great, but I could imagine some hellish future Crawl where Donald says "I hate it when I get an arrow in the knee" or player ghosts shout "The cake -- I mean the Orb -- is a lie!"

I don't seriously expect things would ever go that far, but I feel it's worth voicing the concern. I think using Bloax's tile would be fine, especially considering it's a lot better than the original.
(0021125)
minmay (reporter)
2013-02-23 05:20

Well we do already have references to Rick Astley
(0023201)
KiloByte (manager)
2013-06-15 23:53

I've placed this in UNUSED/.

- Issue History
Date Modified Username Field Change
2013-02-17 06:13 Bloax New Issue
2013-02-17 06:13 Bloax File Added: Tomato4.png
2013-02-17 06:27 neil Note Added: 0021052
2013-02-17 06:49 Bloax Note Added: 0021053
2013-02-17 07:14 Bloax File Added: TomatoRapist2.png
2013-02-17 07:14 Bloax Note Added: 0021054
2013-02-17 07:22 Bloax File Added: TomatoRapist3.png
2013-02-17 07:22 Bloax Note Edited: 0021054
2013-02-17 13:23 KiloByte Note Added: 0021055
2013-02-17 23:25 Napkin File Deleted: TomatoRapist2.png
2013-02-17 23:25 Napkin File Deleted: TomatoRapist3.png
2013-02-17 23:26 Napkin File Added: Tomato5.png
2013-02-17 23:31 neil Note Added: 0021058
2013-02-18 00:20 Bloax Note Added: 0021060
2013-02-18 23:30 KiloByte Note Added: 0021072
2013-02-19 00:41 Bloax File Added: Tomato6.png
2013-02-19 00:42 Bloax Note Added: 0021073
2013-02-19 03:14 Bloax File Added: Tomato7.png
2013-02-19 03:15 Bloax Note Edited: 0021073
2013-02-19 07:32 minmay Note Added: 0021078
2013-02-19 12:52 mumra Note Added: 0021079
2013-02-19 14:30 KiloByte Note Added: 0021080
2013-02-19 15:23 Bloax Note Added: 0021081
2013-02-19 15:24 Bloax Note Edited: 0021081
2013-02-19 15:38 KiloByte Note Added: 0021082
2013-02-19 15:51 mumra Note Added: 0021083
2013-02-19 15:51 mumra Note Edited: 0021083
2013-02-19 16:24 KiloByte Note Added: 0021084
2013-02-19 16:56 mumra Note Added: 0021085
2013-02-19 20:31 Bloax Note Added: 0021086
2013-02-19 20:32 Bloax File Added: Tomato8.png
2013-02-20 12:01 roctavian Note Added: 0021091
2013-02-20 14:27 KiloByte Note Added: 0021092
2013-02-20 19:07 Bloax Note Added: 0021101
2013-02-20 19:08 Bloax Note Edited: 0021101
2013-02-22 11:52 roctavian Note Added: 0021112
2013-02-23 05:20 minmay Note Added: 0021125
2013-06-15 23:53 KiloByte Note Added: 0023201
2013-06-15 23:53 KiloByte Status new => resolved
2013-06-15 23:53 KiloByte Fixed in Branch => 0.13 development branch
2013-06-15 23:53 KiloByte Resolution open => done
2013-06-15 23:53 KiloByte Assigned To => KiloByte


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker