Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006644 [DCSS] Bug Report major random 2013-02-14 07:05 2013-12-17 20:04
Reporter Medar View Status public  
Assigned To Medar
Priority normal Resolution done  
Status closed   Product Branch 0.12 ancient branch
Summary 0006644: On occasion single tiles don't update properly in WebTiles
Description Playing on WebTiles, sometimes (rarely) a tile doesn't update properly. Attached is an example where Urug moved next to me after I killed a kobold, but instead of showing Urug it shows the tile for the dead kobold. This was fixed by pressing escape (for unknown command).

I later had an issue with Joseph shown holding a sling even though he was using a quaterstaff.

Firefox 18.0.2, Windows 7
Additional Information
Tags No tags attached.
Attached Files png file icon urugthekobold.png [^] (258,498 bytes) 2013-02-14 07:05
? file icon Medar.cs [^] (57,675 bytes) 2013-05-28 17:09

- Relationships
has duplicate 0007328closedMedar In a crowd of monsters, the one that appears to be adjacent is not the one the game thinks is adjacent 
has duplicate 0007744resolvedMedar Orc knight is displayed as a hobgoblin 

-  Notes
(0021393)
edlothiol (developer)
2013-03-13 13:11

Hm. Could you check if there are any javascript errors if this happens again?
(0021791)
Medar (developer)
2013-03-25 07:52

Happened again. Couldn't see anything in the error console.
(0022913)
Medar (developer)
2013-05-28 17:16

This bug doesn't seem so rare after all. Especially incorrect weapons show up often.

Managed to make a reproducible case. If you load the attached save and move right both orc tiles show with daggers, even though one is actually wielding a hammer.

There seems to be a broken assumption that if the fg tile didn't change neither did mcache. Removing the test for fg_changed on tileweb.cc:1092 resolves the issue. I assume this would cause lot of unnecessary information to be sent though and an another test for whether mcache has been changed has to be done somehow.
(0024758)
Medar (developer)
2013-12-17 20:04

Should finally be fixed in trunk, 0.14-a0-1528-g95ec8bc.

- Issue History
Date Modified Username Field Change
2013-02-14 07:05 Medar New Issue
2013-02-14 07:05 Medar File Added: urugthekobold.png
2013-03-13 13:11 edlothiol Note Added: 0021393
2013-03-25 07:52 Medar Note Added: 0021791
2013-05-28 17:09 Medar File Added: Medar.cs
2013-05-28 17:16 Medar Note Added: 0022913
2013-07-15 17:29 Medar Relationship added has duplicate 0007328
2013-07-15 17:40 battaile Issue Monitored: battaile
2013-12-03 00:41 Medar Relationship added has duplicate 0007744
2013-12-17 20:04 Medar Note Added: 0024758
2013-12-17 20:04 Medar Status new => resolved
2013-12-17 20:04 Medar Fixed in Branch => 0.14 development branch
2013-12-17 20:04 Medar Resolution open => done
2013-12-17 20:04 Medar Assigned To => Medar
2013-12-17 20:04 Medar Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker