Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006627 [DCSS] Documentation trivial N/A 2013-02-10 23:59 2014-05-20 04:05
Reporter gutt View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0006627: add/modify lines to init.txt and/or options_guide.txt
Description "A good number of runrest_messages is defined by default"
SHOULD READ.......................'are'

Copy/pasting these lines from options_guide.txt to init.txt, I
encountered some lovely startup errors:
" runrest_ignore_message = You feel.*sick"
" runrest_ignore_poison = 4:100"
SHOULD READ.......................'+='

I couldn't find the following line in init.txt, though it is in options_guide.txt:
"spell_slot += <regex>:<list of spell letters>"

The following lines in init.txt appear in a different order than
their respective explainations in options_guide.txt making
for less intuitive following:

# mlist_min_height = 4
# msg_min_height = 7
# msg_max_height = 10
# mlist_allow_alternate_layout = true
# messages_at_top = true
# mlist_targetting = true
# show_gold_turns = false
# show_game_turns = false
# show_newturn_mark = false
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0021000)
neil (administrator)
2013-02-11 02:00

The section numbers need updated as well.
(0021004)
chris (updater)
2013-02-11 18:44

In my opinion maintaining two different files for this purpose is not the best solution.
I wouldn't mind removing init.txt entirely (or keeping its header only) and focusing on options_guide.txt.
(0021005)
KiloByte (manager)
2013-02-11 23:01

init.txt is far more convenient to use than the wordy guide. I fail to see any purpose in it having numbered sections, though.
(0026225)
wheals (administrator)
2014-05-20 04:04

Synchronized the section numbers.

Getting rid of init.txt doesn't sounds like a bad idea if only because of the confusion due to the difference between the values it has (which are the non-default ones) and the values options_guide has, but that's another issue.

- Issue History
Date Modified Username Field Change
2013-02-10 23:59 gutt New Issue
2013-02-11 02:00 neil Note Added: 0021000
2013-02-11 02:00 neil Status new => confirmed
2013-02-11 18:44 chris Note Added: 0021004
2013-02-11 23:01 KiloByte Note Added: 0021005
2013-05-21 18:39 mumra Issue Monitored: mumra
2014-05-20 04:04 wheals Note Added: 0026225
2014-05-20 04:05 wheals Status confirmed => resolved
2014-05-20 04:05 wheals Fixed in Branch => 0.15 development branch
2014-05-20 04:05 wheals Resolution open => done
2014-05-20 04:05 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker