Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006578 [DCSS] Bug Report minor always 2013-01-28 19:54 2015-05-09 07:54
Reporter BlackSheep View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0006578: Monster thrown nets deal damage
Description Nets thrown by monsters can deal damage. This is most apparent on higher HD monsters like merfolk.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Removed-damage-from-nets-thrown-by-monsters.patch [^] (793 bytes) 2013-02-26 08:32 [Show Content]

- Relationships

-  Notes
(0021160)
AriaB (reporter)
2013-02-25 23:59
edited on: 2013-02-26 00:00

Looked over this, does not appear to be a bug. Thrown nets should do damage based on the strength of the monster. Basically, the net is being thrown VERY HARD, so it hurts.

(0021165)
BlackSheep (reporter)
2013-02-26 04:00

From throw.cc:

"// Nets use throwing skill. They don't do any damage!"
(0021166)
AriaB (reporter)
2013-02-26 04:33

Hm. So the question seems to be:

Nets should:
    Not do damage when thrown by anything.
    Do damage when thrown by anything.
    Only do damage when thrown by monsters. (I'm assuming this is the current state.)

I was about to work on this issue but the feedback I got from the IRC channel was that net deaths are more interesting than not.
(0021171)
AriaB (reporter)
2013-02-26 08:35

I added a patch which removes damage from nets thrown by monsters; I'll leave it up to the devs to decide if it should be this way.
(0029021)
PleasingFungus (administrator)
2015-05-09 07:54

This was fixed in 0.15.

- Issue History
Date Modified Username Field Change
2013-01-28 19:54 BlackSheep New Issue
2013-02-25 23:59 AriaB Note Added: 0021160
2013-02-26 00:00 AriaB Note Edited: 0021160
2013-02-26 04:00 BlackSheep Note Added: 0021165
2013-02-26 04:33 AriaB Note Added: 0021166
2013-02-26 08:32 AriaB File Added: 0001-Removed-damage-from-nets-thrown-by-monsters.patch
2013-02-26 08:35 AriaB Note Added: 0021171
2015-05-09 07:54 PleasingFungus Note Added: 0029021
2015-05-09 07:54 PleasingFungus Status new => resolved
2015-05-09 07:54 PleasingFungus Fixed in Branch => 0.16 pre-release branch
2015-05-09 07:54 PleasingFungus Resolution open => done
2015-05-09 07:54 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker