Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006562 [DCSS] Patches feature N/A 2013-01-22 21:09 2014-10-12 03:06
Reporter argonaut View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006562: Reorder inventory categories
Description It's nice to see all the things you can wield on the same page of the inventory screen. This patch puts staves and rods just after armour and moves food towards the end.

The easy way to change it would be in enum.h but that would muck with saves so the patch does a bit of indirection before the inventory menus are generated.
Additional Information
Tags No tags attached.
Attached Files ? file icon inventory_menus.patch [^] (974 bytes) 2013-01-22 21:09 [Show Content]

- Relationships

-  Notes
(0027308)
wheals (administrator)
2014-09-19 02:01

A thing I've wanted for so long, and it turns out it's been rotting on Mantis forever? Amazing! Added in 0.16-a0-671-g9ab8c9f.
(0027459)
chris (updater)
2014-10-10 02:17

Does this also handle chardumps?
(0027471)
wheals (administrator)
2014-10-12 03:06

0.16-a0-1215-g30a626a should.

- Issue History
Date Modified Username Field Change
2013-01-22 21:09 argonaut New Issue
2013-01-22 21:09 argonaut File Added: inventory_menus.patch
2014-01-30 09:29 Medar Issue Monitored: Medar
2014-09-19 02:01 wheals Note Added: 0027308
2014-09-19 02:01 wheals Status new => resolved
2014-09-19 02:01 wheals Fixed in Branch => 0.16 development branch
2014-09-19 02:01 wheals Resolution open => done
2014-09-19 02:01 wheals Assigned To => wheals
2014-10-10 02:17 chris Note Added: 0027459
2014-10-12 03:06 wheals Note Added: 0027471


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker