Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006548 [DCSS] Bug Report minor always 2013-01-18 10:16 2014-01-30 08:04
Reporter nago View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0006548: There's no warning if attacking an helpless foo with portal projectile under TSO
Description If you attack a monster who is helpless (confused, sleeping, etc.) shooting with portal projectile, there's no warning that action will put right under penance by TSO, while all other attack actions have one.
Additional Information
Tags patch
Attached Files ? file icon 6548_patch_1.diff [^] (3,896 bytes) 2013-02-04 01:31 [Show Content]

- Relationships
has duplicate 0006835resolvedmumra Portal projectile angers TSO without prompt 

-  Notes
(0020827)
blackcustard (reporter)
2013-01-19 04:55

Crawl deliberately avoids "tracing" for portaled projectiles, just as it does for projectiles thrown while confused. The point of the tracing process is to bring up this prompt, and other prompts like it.

Does this mean that this is NOT a bug? I think it is still a bug, but a somewhat subtle one.

I think the intent was this: a portaled projectile teleports to its destination, so there's no need to check for stuff we don't want to hit along the way--the projectile can't hit anything else because it's not flying across the level. The bug is that it doesn't check the destination either.

I'm working on a patch. I won't finish it tonight though, I'm trying to figure out the right way to fix this.
(0020955)
blackcustard (reporter)
2013-02-04 03:39

I don't know if this is the right way to fix it or not: I added a call to stop_attack_prompt inside throw_it, just for portaled.

I tested to verify that:
-When you strike a sleeping monster with portaled projectile or a thrown projectile while worshipping TSO you are warned.
-If you strike anyway you go into penance.
-If you strike a non-helpless monster with portaled projectile or a thrown projectile while worshipping TSO you are NOT warned.

I was hoping for some feedback on part of the code:
+ // Kludgy. Ideally this would handled by the same code.
+ // Perhaps some notion of a zero length bolt, with the source and
+ // target both set to the target?

Anyway, here's a working patch which is more or less ready to go. I think.
(0025140)
Medar (developer)
2014-01-30 08:04
edited on: 2014-01-30 08:04

Applied to trunk in: 0.14-a0-2343-gc2bc827

I added a test to avoid losing a turn when canceling the attack. And the next commit fixes a duplicate MSG_OK print, which was already happening if you canceled a normal throwing attack.

Sorry that this took so (very) long. Poking people in ##crawl-dev on FreeNode might help in cases where patches seem to be forgotten about.


- Issue History
Date Modified Username Field Change
2013-01-18 10:16 nago New Issue
2013-01-19 01:24 blackcustard Status new => acknowledged
2013-01-19 04:55 blackcustard Note Added: 0020827
2013-02-04 01:31 blackcustard File Added: 6548_patch_1.diff
2013-02-04 03:39 blackcustard Note Added: 0020955
2013-02-04 04:12 blackcustard Issue Monitored: blackcustard
2013-02-04 04:13 blackcustard Status acknowledged => feedback
2013-03-27 19:03 mumra Relationship added has duplicate 0006835
2013-04-20 12:51 Medar Tag Attached: patch
2014-01-30 08:04 Medar Note Added: 0025140
2014-01-30 08:04 Medar Status feedback => resolved
2014-01-30 08:04 Medar Fixed in Branch => 0.14 development branch
2014-01-30 08:04 Medar Resolution open => done
2014-01-30 08:04 Medar Assigned To => Medar
2014-01-30 08:04 Medar Note Edited: 0025140


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker