Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006543 [DCSS] Bug Report feature always 2013-01-18 00:32 2014-06-11 17:03
Reporter battaile View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.12 ancient branch
Summary 0006543: ctrl+T settings reset every time you change floor
Description The setting for what your allies pick up as far as gear goes (ctrl+T) gets reset every time you change floor. (ie go up or down stairs).

I'm not sure this is a bug, perhaps its by design, but even if it is, could we consider changing it? Personally I find it somewhat annoying to have to reset it every floor, and I frequently forget to do so.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020814)
KiloByte (manager)
2013-01-18 00:38

I asked jpeg about this subject a couple of years ago, she said it was intentional but couldn't recall the reason. No one else I asked had a clue.
(0021024)
battaile (reporter)
2013-02-14 15:54

It looks like the way it works is that you actually have a distinct setting for every floor that gets remembered. I'm guessing this is to facilitate things like protecting your stash and/or levels that you know will have some nice items (Slime 6, Vault 5 etc).

So anyway, sounds like its working as intended and with a reason so feel free to close this one.
(0021029)
KiloByte (manager)
2013-02-14 19:19

No, that's not the case -- the setting is never stored, and gets removed when you:
* load a game
* enter a new level for the first time

Even if for some reason resetting of this setting should be kept, at least these two rules need to be replaced with something reasonable.
(0026452)
wheals (administrator)
2014-06-11 16:57

The ctrl-t setting is gone, so this can be resolved.

- Issue History
Date Modified Username Field Change
2013-01-18 00:32 battaile New Issue
2013-01-18 00:38 KiloByte Note Added: 0020814
2013-02-14 15:54 battaile Note Added: 0021024
2013-02-14 19:19 KiloByte Note Added: 0021029
2013-02-14 19:27 battaile Note Added: 0021030
2013-02-14 19:27 battaile Note Deleted: 0021030
2013-03-19 14:43 battaile Issue Monitored: battaile
2013-03-21 19:21 battaile Issue End Monitor: battaile
2014-06-11 16:57 wheals Note Added: 0026452
2014-06-11 16:57 wheals Status new => resolved
2014-06-11 16:57 wheals Fixed in Branch => 0.15 development branch
2014-06-11 16:57 wheals Resolution open => done
2014-06-11 16:57 wheals Assigned To => wheals
2014-06-11 17:03 battaile Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker