Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006505 [DCSS] Upload: Maps and Vaults feature N/A 2013-01-07 23:09 2016-06-12 23:33
Reporter argonaut View Status public  
Assigned To Claws
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006505: Myth-based vaults
Description A few vaults referencing the Greek myths. The Titan can appear at a low depth but is easily avoided.
Additional Information
Tags No tags attached.
Attached Files ? file icon greek_myths.des [^] (2,633 bytes) 2013-01-07 23:09 [Show Content]
? file icon greek_myths-1.des [^] (2,694 bytes) 2013-01-08 17:33 [Show Content]
? file icon greek_myths-2.des [^] (2,992 bytes) 2013-02-12 19:56 [Show Content]

- Relationships

-  Notes
(0020740)
KiloByte (manager)
2013-01-08 00:21

Multiple death yaks are probably going to kick too much behind on D:8.

Vault monsters should never be att:friendly, as Oka and Ely will punish you, and if you manage to kill the enemy on time, you get a permanent ally. Add polymorph abuse, and it can get naught...
(0020744)
argonaut (reporter)
2013-01-08 17:33

Issues fixed. I hadn't figured on ally abuse.
(0020983)
infiniplex (reporter)
2013-02-09 04:53

fire_from_heaven
-> Remove the .. from "KMONS:..2 = patrolling raven". As is, I think it will put a raven on every '.' cell.
-> I would add a @ to the top right corner as well.

augean_stables
-> Are you sure you want "ORIENT: float"? It looks like it should be along the south side of the map.
-> If you don't want your river to turn into (almost all) shallow water, add the no_pool_fixup tag

gorgon_sisters
-> Change "spells:petrify;petrify; ; ; ;" to "spells:petrify;petrify;.;.;.;."
-> Using harpies as the base creature for gorgons means that they steal your food. Given the mythical connotations, I would suggest using a merfolk or naga as the base creature. A mermaid would have the "she" pronouns, but shewould keep her mesmerize ability.
-> Start the mirror shield identified and move it closer to the entrance. The effect is lost as is.

golden_fleece
-> An animal skin is pretty bad even with the positive energy ego. I would consider making it "animal skin randart" or increasing the gold.

sea_monster_sacrifice
-> Both the sea snake and the human start on land tiles. Use KFEAT: to fix this. I would start the sea monster on deep water ('w') and the human in shallow water ('W').
-> I would add a row of deep water to the top and bottom as padding.
-> The "sacrificial" name_adjective is already used, so you get a description clash. I would have guessed the Hellbinder wizlab, be it turns out not to be there. If there is no longer a "sacrificial human" elsewhere, the discription could probably be changed to match your vault.
(0021009)
argonaut (reporter)
2013-02-12 20:11

Made most of the suggested changes. I kept the gorgons as Harpies since they're often depicted as winged - plus I liked the batty behavior in the vault.

The golden_fleece is now oriented in a corner where it seems to work better. Is there any way to give a name to a randart?

fire_from_heaven now has a chance of a book with either conjure flame or firestorm (both smite targeted and fit the theme).
(0021010)
KiloByte (manager)
2013-02-12 21:48

Artefacts with a name and a tile do exist. What you're looking for is "fixedart".

A fixedart with random properties does exist (the faerie dragon armour), although in this case it's pretty obvious you'd want a regular unrand. Which can have not only any stats you wish, but even unique custom code.
(0030625)
Claws (developer)
2016-06-12 23:32

Finally gotten around to in a0c350b, with a bunch of edits due to this being three and a half years old. Ravens replaced with caustic shrikes, vault monster gorgons replaced with other petrifying monsters, and the dragon's island altered on its edges to allow autoexplore to see it + almost support letting the dragons stay awake.

I'm vetoing sea_monster_sacrifice due to it being way too easy to fight Cetus as a regular wandering floor spawn after it wakes up and kills Andromeda, though- outside of source-reading, Crawl's mechanics just don't support the vault.

Thanks for the submission! Sorry it took forever to get around to it.

- Issue History
Date Modified Username Field Change
2013-01-07 23:09 argonaut New Issue
2013-01-07 23:09 argonaut File Added: greek_myths.des
2013-01-08 00:21 KiloByte Note Added: 0020740
2013-01-08 17:33 argonaut File Added: greek_myths-1.des
2013-01-08 17:33 argonaut Note Added: 0020744
2013-02-09 04:53 infiniplex Note Added: 0020983
2013-02-12 19:56 argonaut File Added: greek_myths-2.des
2013-02-12 20:11 argonaut Note Added: 0021009
2013-02-12 21:48 KiloByte Note Added: 0021010
2016-06-12 23:32 Claws Note Added: 0030625
2016-06-12 23:33 Claws Status new => resolved
2016-06-12 23:33 Claws Fixed in Branch => 0.19 development branch
2016-06-12 23:33 Claws Resolution open => done
2016-06-12 23:33 Claws Assigned To => Claws


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker