Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006503 [DCSS] Bug Report minor always 2013-01-07 18:45 2018-03-24 18:09
Reporter elliptic View Status public  
Assigned To advil
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006503: Autoexplore ignored sleeping wolf spider.
Description Autoexplore took me into a room with a sleeping wolf spider and autopicked up an item several squares into the room. Then it started to take me out of the room, stopping only when the wolf spider woke up. There was no strange terrain between me and the spider.
Additional Information
Tags No tags attached.
Attached Files ? file icon elliptic.cs [^] (1,041,340 bytes) 2018-03-24 17:08

- Relationships
has duplicate 0010223resolvedwheals Autoexplore occasionally ignores sleeping monsters 
has duplicate 0011089resolvedPleasingFungus Autoexplore ignores sleeping monsters 
has duplicate 0011322closedadvil Autoexploring Ignoring Enemies 

-  Notes
(0020738)
elliptic (developer)
2013-01-07 19:10

Autoexplore ignoring a sleeping monster can be reproduced in http://dobrazupa.org/saves/elliptic-crawl-git-e3ef79a55b-130107-1805.tar.bz2 [^] -- move east one square into view of the sleeping stone giant skeleton and then autoexplore.
(0021144)
rchandra (reporter)
2013-02-24 09:11

http://dobrazupa.org/saves/rchandra-crawl-git-3363fc0b84-130224-0809.tar.bz2 [^]
http://dobrazupa.org/saves/rchandra-crawl-git-2521a5a6b8-130224-0809.tar.bz2 [^]

In this game, (saves included before and after an update) I have the same behaviour, with a wolf spider in Vaults. I can press o to explore with the spider in view.
(0027355)
neil (administrator)
2014-09-25 20:52
edited on: 2014-09-25 21:04

This became much more common for a while in 0.16 (0.16-a0-364-g6693b33 to 0.16-a0-779-g6d4cac7). It can still happen if monster of sufficiently low intelligence without ranged attacks can see you, but has to take more than 8 or 10 steps to get to you (because of terrain). See the use of mons_tracking_range in _mons_has_path_to_player (misc.cc).

(0028349)
PleasingFungus (administrator)
2015-01-24 06:52

I seem to remember this being fixed?
(0028664)
elliptic (developer)
2015-03-19 15:04

I've had this happen multiple times in my current game (a Fo of Ash, so monster detection could be relevant I guess). The first time was a yellow wasp and the second was an entire band of slime creatures. In both cases autoexplore actually took me adjacent to a monster (in open terrain), so not the situation mentioned in neil's comment.
(0028665)
elliptic (developer)
2015-03-19 15:07

(current game is 0.16.0-16-g311141a)
(0028684)
Arrhythmia (reporter)
2015-03-23 01:08
edited on: 2015-03-23 01:09

I have also seen this bug while playing OPFE^Ash; the ignored monster was a komodo-dragon which I had sensed, but not seen. e: Version is .16.0

(0032141)
advil (administrator)
2018-03-24 17:11
edited on: 2018-03-24 17:14

The older saves don't seem to illustrate this issue any more, but here is an upgraded version of elliptic's save that does illustrate the ash version of it, based on some recent screenshots I've seen. The frog to the right won't prevent shift-movement or autoexplore until you're one space away. It is completely replicable: the condition to set this up was, 1. place monster in that position, move out of view, forgot monsters in the map, 2. first detect the monster via ash, and 3. then go move towards it. Step 2 is necessary in my testing.

At least one recent report isn't ash, though, so there may be other related bugs.

(0032145)
advil (administrator)
2018-03-24 17:20

Also works via boots of the assassin, as in 0011322
(0032146)
advil (administrator)
2018-03-24 18:09

Ok, I think I got this one, in https://github.com/crawl/crawl/commit/822b61bbc798 [^]

- Issue History
Date Modified Username Field Change
2013-01-07 18:45 elliptic New Issue
2013-01-07 19:10 elliptic Note Added: 0020738
2013-01-07 19:11 elliptic Reproducibility unable to reproduce => always
2013-02-24 09:11 rchandra Note Added: 0021144
2014-09-25 20:52 neil Note Added: 0027355
2014-09-25 21:04 neil Note Edited: 0027355
2015-01-24 06:52 PleasingFungus Note Added: 0028349
2015-03-19 15:04 elliptic Note Added: 0028664
2015-03-19 15:07 elliptic Note Added: 0028665
2015-03-23 01:08 Arrhythmia Note Added: 0028684
2015-03-23 01:09 Arrhythmia Note Edited: 0028684
2016-01-04 13:40 wheals Relationship added has duplicate 0010223
2017-06-05 16:52 PleasingFungus Relationship added has duplicate 0011089
2018-03-24 15:35 advil Relationship added has duplicate 0011322
2018-03-24 17:08 advil File Added: elliptic.cs
2018-03-24 17:11 advil Note Added: 0032141
2018-03-24 17:14 advil Note Edited: 0032141
2018-03-24 17:20 advil Note Added: 0032145
2018-03-24 18:09 advil Note Added: 0032146
2018-03-24 18:09 advil Status new => resolved
2018-03-24 18:09 advil Fixed in Branch => 0.22 development branch
2018-03-24 18:09 advil Resolution open => done
2018-03-24 18:09 advil Assigned To => advil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker