Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006463 [DCSS] Patches feature N/A 2012-12-22 19:01 2013-05-31 15:14
Reporter Eronarn View Status public  
Assigned To mumra
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006463: Lava orcs for .12 in '12
Description Most of the objections to merging lava orcs have been addressed, and a version of the `lava_orc` branch rebased for current master is available here: https://github.com/Eronarn/Crawling-Chaos/tree/lava_orc [^]

Lava orcs have these changes since their last iteration:

* Different apts, based on the new hill orc ones (again)
* Slow movement at low temperature and fast movement at high temperature
* Slow entering and exiting of lava
* Temperature change capped at a maximum of one per turn (excepting special cases)
* Reworked tension scaling
* Beoghite lava orcs do not harm friendly, Beogh-aligned orcs with their heat aura
* Tiles and webtiles support for lava orcs looking 'hotter' with temperature and lava orc heat auras
* Improved temperature graph and messaging
* Bug fixes

This is the third go-around, so relative to their first iteration, they also have:

* Different apts, based on the new hill orc ones
* Heat aura is less damage, less size, and only occurs at maxed out temperature
* Passive heat is less damage and occurs at a higher temperature
* Tweaks to the display screen
* Tweaks to how temperature is calculated
* Many bug fixes as a result of the above

I've also implemented an experimental change to tension in the `tension` branch (https://github.com/Eronarn/Crawling-Chaos/tree/tension). [^] I haven't put this change in the main `lava_orc` branch because it also affects Xom, demonic guardian, and so on; however, it would probably be beneficial for lava orc gameplay.

The current formula multiplies tension by maxHP * 2, then divides it by maxHP + minHP. This means that tension at 1/300 HP is not even twice that of tension at 300/300 HP. I've changed this formula to use sqrt(1 + %damage). This makes HP loss cause more extreme tension swings: at 1/300 HP, your tension will be 10x what it is when you are at 300/300 HP (making for 5x what it would currently be in that situation). If desired, an additional /2 could be added into the mix - this means you'd be at 1/2 of current tension when at 100% life scaling up to 2.5x current tension when nearly dead.

As an aside, I know this is a duplicate ticket (https://crawl.develz.org/mantis/view.php?id=5154). [^] Note the submission date: 2012-01-01 05:19. I'd really like to see them merged into trunk before 2013!
Additional Information
Tags No tags attached.
Attached Files

- Relationships
parent of 0003687resolvedmumra Reading a book uses the scroll-reading code 
related to 0005154resolvedmumra The new and improved lava orcs 

-  Notes
(0020671)
Kyrris (reporter)
2012-12-24 08:56

Is there any chance at this late stage of seeing them renamed something with more character? Derived from one of the Pacific Rim volcano gods, maybe? Lava Orc is just a terrible name for a genuinely fun race.
(0020682)
brendan (developer)
2012-12-27 04:34

Eronarn: As discussed, please open a merge (pull?) request on gitorious.
Given the size of this change I'd like to provide line comments.

Kyrris: I'll stay out of the naming fray. How about Vesuvians? ;)
(0022965)
mumra (developer)
2013-05-31 15:14

Lava orcs have been merged in trunk so I'll close this old ticket, any bugs that emerge should be new tickets, and further discussion should go to ##crawl-dev/wiki/forum.

- Issue History
Date Modified Username Field Change
2012-12-22 19:01 Eronarn New Issue
2012-12-24 08:56 Kyrris Note Added: 0020671
2012-12-27 04:34 brendan Note Added: 0020682
2013-03-14 04:09 mumra Relationship added related to 0005154
2013-03-14 04:11 mumra Relationship added parent of 0003687
2013-05-31 15:14 mumra Note Added: 0022965
2013-05-31 15:14 mumra Status new => resolved
2013-05-31 15:14 mumra Fixed in Branch => 0.13 development branch
2013-05-31 15:14 mumra Resolution open => done
2013-05-31 15:14 mumra Assigned To => mumra


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker