Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006439 [DCSS] Patches crash always 2012-12-13 03:31 2015-12-02 21:19
Reporter blmarket View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006439: Some fonts makes crawl crashes while loading
Description To translate crawl to korean, I'm using other fonts like nanum-coding(you can install it in ubuntu by selecting fonts-nanum-coding package).

But while precaching glyphs, game crashes due to glyphs < and > in font has larger size than its m_max_height or m_max_width.

you can reproduce crash step by
make debug TILES=y MONOSPACED_FONT=/usr/share/fonts/truetype/nanum-coding/NanumGothic_Coding.ttf
./crawl


I think it would be better to calculate font size by iterating all the glyphs, but Korean characters are too many(over 10000) so it may slows loading game.

So my simple patch handling this issue is attached. it crops glyph bitmap to allocated character size, calculated by charsz.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0002-Cut-glyphs-if-it-s-larger-than-charsz.patch [^] (1,630 bytes) 2012-12-13 03:37 [Show Content]

- Relationships

-  Notes
(0020622)
blmarket (reporter)
2012-12-13 03:38

sorry, my first patch has potential bug. Can you delete 0001 and apply 0002 instead?
(0025900)
Reaver (developer)
2014-04-24 05:07

I deleted 0001 and updated issue to crash severity.
(0029902)
wheals (administrator)
2015-12-02 21:19

I couldn't reproduce the crash, but the patch didn't cause anything to go wrong either, so I pushed it in https://github.com/crawl/crawl/commit/97aafa44166f. [^]

- Issue History
Date Modified Username Field Change
2012-12-13 03:31 blmarket New Issue
2012-12-13 03:31 blmarket File Added: 0001-Cut-glyphs-if-it-s-larger-than-charsz.patch
2012-12-13 03:37 blmarket File Added: 0002-Cut-glyphs-if-it-s-larger-than-charsz.patch
2012-12-13 03:38 blmarket Note Added: 0020622
2013-01-06 23:28 frogbotherer Issue Monitored: frogbotherer
2014-01-30 09:30 Medar Issue Monitored: Medar
2014-04-24 05:07 Reaver Note Added: 0025900
2014-04-24 05:07 Reaver File Deleted: 0001-Cut-glyphs-if-it-s-larger-than-charsz.patch
2014-04-24 05:07 Reaver Severity minor => crash
2014-04-24 05:07 Reaver Description Updated
2015-12-02 21:19 wheals Note Added: 0029902
2015-12-02 21:19 wheals Status new => resolved
2015-12-02 21:19 wheals Fixed in Branch => 0.18 development branch
2015-12-02 21:19 wheals Resolution open => done
2015-12-02 21:19 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker