Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006425 [DCSS] Bug Report crash always 2012-12-02 07:04 2015-02-25 15:58
Reporter tempest View Status public  
Assigned To frogbotherer
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006425: Crash on startup, Android 4.2
Description Works like a charm on Android 4.1, but crashes every time on launch after update to 4.2.

Log file lifted from the forums of another user with the same issue.

http://pastebin.com/Kw1fD1W6 [^]

Relevant thread: https://crawl.develz.org/tavern/viewtopic.php?f=8&t=5644&start=50 [^]
Additional Information
Tags crash
Attached Files

- Relationships

-  Notes
(0020630)
tempest (reporter)
2012-12-14 17:44

I have confirmed that this issue still persists in the latest build: 0.12-a0-1308-g1601c0d
(0020697)
Soobin (reporter)
2013-01-01 04:58

Even in the build of new year: 0.12-a0-1539-ge2ba925
(0020729)
Amnesiac (reporter)
2013-01-05 13:42
edited on: 2013-01-08 11:24

I'm using android 4.0.4.
0.12-a0-1308-g1601c0d worked but with wrong animated skeleton(and, I think, zombie) tiles(I haven't ventured past a few dungeon levels, so I don't know if more bugs would await me on deeper levels).

0.12-a0-1539-ge2ba925 crashes before you can "press any key".

0.12-a0-1447-gab12c06 crashes, too

0.12-a0-1609-g7768dbe still crashes on start.

btw, when I installed 1539 over 1308 it worked but with wrong tiles, mb devs forgot to delete the old one before installing the new one and thought that it works? I know the probability of this is low, but what if.

(0020758)
barbs (reporter)
2013-01-12 07:08

Hi guys, I'm the developer of the unofficial ASCII Android app. I randomly decided to check on how the graphical one was progressing, and noticed you'd run into a similar problem here (crashing on Android 4.2).

It looks like the same bug I was experiencing...it's actually a problem with the CrystaX toolchain used to compile the game. This has been recognised, and has actually been fixed by CrystaX in the latest build of his toolchain (beta3). http://www.crystax.net/trac/ndk/ticket/112 [^]

HOWEVER, this new version seems to introduce another bug, where internal storage can't be read by native code. This caused my app to fail on all versions of Android. I've created a defect for this problem, but CrystaX hasn't looked at it yet (http://www.crystax.net/trac/ndk/ticket/126). [^]

So, to work around it, I used the workaround he mentioned in the original bug (defining the __exidx_start() and __exidx_end() methods), and I compiled using the old beta2 toolchain. This allows it to work with all versions of Android including 4.2.

Hope this helps!
(0020832)
Soobin (reporter)
2013-01-20 02:13

Finally, it works.
(0020842)
Amnesiac (reporter)
2013-01-21 06:23
edited on: 2013-01-21 06:45

Indeed, it works. I'm going to test it right now.

What I have noticed from last time is that keyboard keys like ctrl and shift don't work. But I guess not many people would connect a keyboard to they android device as it won't be as portable.

(0028571)
wheals (administrator)
2015-02-25 15:58

It seems to work, and I haven't heard any complaints recently about this. Thanks barbs for fixing it!

- Issue History
Date Modified Username Field Change
2012-12-02 07:04 tempest New Issue
2012-12-14 17:44 tempest Note Added: 0020630
2012-12-14 17:44 tempest Issue Monitored: tempest
2012-12-26 12:24 orthagh Issue Monitored: orthagh
2012-12-31 05:43 Naphistim Issue Monitored: Naphistim
2013-01-01 04:54 Soobin Issue Monitored: Soobin
2013-01-01 04:58 Soobin Note Added: 0020697
2013-01-01 22:24 Naphistim Tag Attached: crash
2013-01-03 17:40 frogbotherer Status new => assigned
2013-01-03 17:40 frogbotherer Assigned To => frogbotherer
2013-01-05 13:42 Amnesiac Note Added: 0020729
2013-01-05 13:45 Amnesiac Note Edited: 0020729
2013-01-05 13:45 Amnesiac Note Edited: 0020729
2013-01-05 13:46 Amnesiac Note Edited: 0020729
2013-01-05 13:46 Amnesiac Note Edited: 0020729
2013-01-05 13:47 Amnesiac Note Edited: 0020729
2013-01-05 13:51 Amnesiac Note Edited: 0020729
2013-01-05 13:52 Amnesiac Note Edited: 0020729
2013-01-05 13:55 Amnesiac Note Edited: 0020729
2013-01-05 13:57 Amnesiac Note Edited: 0020729
2013-01-05 13:58 Amnesiac Note Edited: 0020729
2013-01-05 14:37 Amnesiac Note Edited: 0020729
2013-01-05 19:55 Amnesiac Note Edited: 0020729
2013-01-07 14:47 Amnesiac Note Edited: 0020729
2013-01-07 14:47 Amnesiac Note Edited: 0020729
2013-01-08 11:24 Amnesiac Note Edited: 0020729
2013-01-12 07:08 barbs Note Added: 0020758
2013-01-20 02:13 Soobin Note Added: 0020832
2013-01-20 02:13 Soobin Issue End Monitor: Soobin
2013-01-21 06:23 Amnesiac Note Added: 0020842
2013-01-21 06:45 Amnesiac Note Edited: 0020842
2015-02-25 15:58 wheals Note Added: 0028571
2015-02-25 15:58 wheals Status assigned => resolved
2015-02-25 15:58 wheals Fixed in Branch => 0.16 development branch
2015-02-25 15:58 wheals Resolution open => done


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker