Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006401 [DCSS] Bug Report crash have not tried 2012-11-23 01:24 2015-02-25 18:22
Reporter Galefury View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006401: tornado crash
Description Crashed soon after casting Tornado in a snake rune vault.
Additional Information
Tags No tags attached.
Attached Files txt file icon crash-Wrigglystuff-20121123-012041.txt [^] (46,903 bytes) 2012-11-23 01:24 [Show Content]
? file icon Wrigglystuff.cs [^] (1,351,934 bytes) 2012-11-23 01:26
? file icon 0001-Make-bennu-revival-a-fineff-6401.patch [^] (6,233 bytes) 2015-02-25 18:06 [Show Content]

- Relationships
has duplicate 0006332resolvedwheals Weird tornado crash 
has duplicate 0009506resolvedwheals "unfortunately your game ended unexpectadly" when killing bennus in ziggurats 

-  Notes
(0020551)
Galefury (updater)
2012-11-23 01:30

I also cast orb of destruction very soon after casting tornado.
(0020552)
KiloByte (manager)
2012-11-23 03:07

The culprit seems to be _rotate() arbitrarily rejecting moves that are not in a straight line. This can end up in an actor having no valid destination, when his current location is already taken. We'd need to ensure that no three move_avail entries allow A->B and B->C but not C->A.

Also, demanding straight lines means a tornado over a 20 aut tick doesn't behave the same as one over two 10 aut ticks.

Is there a simpler way than partitioning mon_act/mon_avail into connected components?
(0020555)
KiloByte (manager)
2012-11-24 03:20

Looks like taking the complement of A, B, C is not that good: in a room shaped like a thickness 2 'H' with the tornado's center in the H's center, victims would get rotated from one side of the H to the other.
(0028554)
wheals (administrator)
2015-02-23 16:39

This is definitely still happening, and seems to be fairly common in fact. :(
(0028574)
neil (administrator)
2015-02-25 18:07

Patch for the bennu case attached.

This could still be a problem for monster felid revival and shambling mangrove fauna.
(0028575)
neil (administrator)
2015-02-25 18:15
edited on: 2015-02-25 18:15

Applied the bennu patch (0.16-a0-4100-gc4bd973). Perhaps this should be kept open until felids and mangroves are fixed as well.

(0028576)
wheals (administrator)
2015-02-25 18:22

Patch now in trunk; we'll see if any more crashes occur.

- Issue History
Date Modified Username Field Change
2012-11-23 01:24 Galefury New Issue
2012-11-23 01:24 Galefury File Added: crash-Wrigglystuff-20121123-012041.txt
2012-11-23 01:26 Galefury File Added: Wrigglystuff.cs
2012-11-23 01:30 Galefury Note Added: 0020551
2012-11-23 03:07 KiloByte Note Added: 0020552
2012-11-24 03:20 KiloByte Note Added: 0020555
2013-04-18 15:42 mumra Issue Monitored: mumra
2015-02-23 16:39 wheals Note Added: 0028554
2015-02-24 17:34 wheals Relationship added has duplicate 0006332
2015-02-25 13:42 wheals Relationship added has duplicate 0009506
2015-02-25 18:06 neil File Added: 0001-Make-bennu-revival-a-fineff-6401.patch
2015-02-25 18:07 neil Note Added: 0028574
2015-02-25 18:15 neil Note Added: 0028575
2015-02-25 18:15 neil Note Edited: 0028575
2015-02-25 18:22 wheals Note Added: 0028576
2015-02-25 18:22 wheals Status new => resolved
2015-02-25 18:22 wheals Fixed in Branch => 0.16 development branch
2015-02-25 18:22 wheals Resolution open => done
2015-02-25 18:22 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker