Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006400 [DCSS] Patches feature have not tried 2012-11-23 01:00 2014-07-04 22:53
Reporter brendan View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.12 ancient branch
Summary 0006400: Penance decreases as a player acquires experience.
Description This patch introduces Ashenzari-style penance reduction for all gods (apart from Nemelex).

If a player is subject to multiple wraths, reduction occurs in a random order. If a player is currently under penance by the god he worships, reduction is always applied to that god first.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Experience-Penance-Timeouts.patch [^] (2,511 bytes) 2012-11-23 01:00 [Show Content]
? file icon 0002-Penance-and-Mollification.patch [^] (4,154 bytes) 2012-11-23 01:00 [Show Content]
? file icon 0003-Penance.patch [^] (22,368 bytes) 2012-11-23 01:00 [Show Content]
? file icon 0004-Penance-Timeout.patch [^] (17,237 bytes) 2012-11-23 01:00 [Show Content]

- Relationships
related to 0002126resolvedmumra God wrath produces moronic play + increased server load 

-  Notes
(0022219)
brendan (developer)
2013-04-09 08:20

I've merged these patches and pushed them to gitorious on the branch 'xpwrath'.
(0025665)
MarvinPA (developer)
2014-03-21 10:22

This has since been implemented, from Grunt's branch.

- Issue History
Date Modified Username Field Change
2012-11-23 01:00 brendan New Issue
2012-11-23 01:00 brendan File Added: 0001-Experience-Penance-Timeouts.patch
2012-11-23 01:00 brendan File Added: 0002-Penance-and-Mollification.patch
2012-11-23 01:00 brendan File Added: 0003-Penance.patch
2012-11-23 01:00 brendan File Added: 0004-Penance-Timeout.patch
2013-04-08 20:01 mumra Issue Monitored: mumra
2013-04-08 20:24 mumra Relationship added related to 0002126
2013-04-09 08:20 brendan Note Added: 0022219
2014-03-21 10:22 MarvinPA Note Added: 0025665
2014-03-21 10:22 MarvinPA Status new => resolved
2014-03-21 10:22 MarvinPA Fixed in Branch => 0.14 development branch
2014-03-21 10:22 MarvinPA Resolution open => done
2014-03-21 10:22 MarvinPA Assigned To => MarvinPA
2014-07-04 22:53 brendan Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker