Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006396 [DCSS] Bug Report major random 2012-11-21 16:47 2013-11-24 13:07
Reporter Ragdoll View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006396: Xom confusion duration lasts forever(30+ turns)
Description Recently I have been playing some games with the new(ish) Xom, and the culprit for most of my deaths are 30+ turn confusion.

The confusion duration is quite excessive. If one is unable to get rid of the confusion by being out of potions or by being a mummy, then you have a big problem.
Shuffling around hopelessly for 30+ turns with monsters attacking you, as xom only does this with monsters on-screen, tend to result in your doom.

No other ailment in this game is quite so excessive in duration. I doubt this was supposed to happen.

I've added some logs below showcasing the general duration of Xom confusion:


http://crawl.develz.org/morgues/trunk/Xom/morgue-Xom-20121120-164612.txt [^]
6624 | D:9 | XOM: confusion
6665 | D:9 | unconfused
--
7956 | Lair:1 | XOM: confusion
7988 | Lair:1 | Xom revived you
7990 | Lair:1 | Slain by a six-headed hydra

http://crawl.develz.org/morgues/trunk/Xom/morgue-Xom-20121114-191133.txt [^]
118538 | Zot:5 | XOM: confusion (+ monsters)
118568 | Zot:5 | HP: 7/224 [tentacled monstrosity (6)]
118569 | Zot:5 | Slain by a tentacled monstrosity

Besides the long duration, Xom has no problem chaining your confusion as your health lowers and the tension rises, making the situation even more hopeless.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0020547)
absolutego (reporter)
2012-11-21 17:52

I second this, it's really bad now that Xom effects are tied to tension. I recently had three consecutive MuCK deaths (lair or earlier) due to long-lasting confusion. Low-duration confusion is acceptable, and something that mummies have to work around, but waiting out 40 turns with enemies on sight (and doing so every game) is just silly.
(0020557)
Bloax (reporter)
2012-11-24 16:21

Being totally silly here, but since this sound pretty damn bad - how about replacing it with a Confusion+Tornado combo?

That'd certainly be wacky.
(0024480)
MarvinPA (developer)
2013-11-24 13:07

Capped confusion at 20 turns (along with some other changes).

- Issue History
Date Modified Username Field Change
2012-11-21 16:47 Ragdoll New Issue
2012-11-21 17:52 absolutego Note Added: 0020547
2012-11-24 16:21 Bloax Note Added: 0020557
2013-11-24 13:07 MarvinPA Note Added: 0024480
2013-11-24 13:07 MarvinPA Status new => resolved
2013-11-24 13:07 MarvinPA Fixed in Branch => 0.14 development branch
2013-11-24 13:07 MarvinPA Resolution open => done
2013-11-24 13:07 MarvinPA Assigned To => MarvinPA


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker