Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000620 [DCSS] FR: Interface Improvements text always 2010-01-30 18:37 2014-09-10 15:53
Reporter Timbermaw View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.6 ancient branch
Summary 0000620: Conjure flame text displays
Description Creatures that step on a conjured flame don't display the "*** is engulfed in flames" message anymore. The message shows up only on the next turn. It's quite annoying not knowing if the creature is being damaged at all or not.
Also, i'd suggest a message indicating if it was successfully casted. Sometimes creatures step on it right after you conjure (hydras, for example) and you have no idea if the monster just stepped on it (ignoring the damage threat) or it failed.
Additional Information this is on version 0.6.0-a1-2917.
Tags No tags attached.
Attached Files

- Relationships
child of 0007071resolvedwheals Numerous issues with Targetting, Tracers, Clouds and Breaths 

-  Notes
(0001861)
Timbermaw (reporter)
2010-01-30 18:39

also, no text is displayed if you try placing it beyond the maximum range. It's very newbie unfriendly!
(0001875)
Nobody (reporter)
2010-01-31 03:41

It also auto-targets enemies even though it can't be placed on one.

And more to the original point, it would also be helpful if the icon for the flame cloud were still visible beneath the creature's icon.
(0002932)
jpeg (manager)
2010-02-24 12:57

Update: The cloud not being described on 'x' was a bug that has now been fixed.

There's still no indication for monsters stepping into clouds, which would be kinda useful to know. (This is the one thing among these listed here that I'd like to see fixed sooner rather than later.)

I get an "Out of range" if I try to place it beyond maximum range. Maybe it was a bug that got fixed?

Auto-targeting is debatable. I think the thought is that the spell is often used to block monsters' progress in a corridor, so you'll want it to be placed close to them.

Displaying clouds underneath the monster tile is a good idea, though not one we'll be able to implement in time for 0.6.
(0006870)
xyblor (reporter)
2010-08-05 20:09

Trying to place conjured flame on a tree gives the message "you can't ignite solid rock!".
(0006871)
minmay (reporter)
2010-08-05 21:58

And trying to place it *through* a tree blabbers about translucent walls.
(0006874)
TGW (reporter)
2010-08-05 23:29

Sucessfully casting Conjure Flame gives no message at all, which bugs me.
(0027183)
wheals (administrator)
2014-09-10 15:53

It gives a message when casted, auto-targeting enemies makes sense since you'll want to cast near one, putting it on a tree gives a message about trees, trees are opaque, and, again, it gives a message when casted. A message when monsters step into clouds might be useful in general, but is not a Conjure Flame-specific problem. Additionally, it might be confusing since the damage only starts the next turn.

- Issue History
Date Modified Username Field Change
2010-01-30 18:37 Timbermaw New Issue
2010-01-30 18:39 Timbermaw Note Added: 0001861
2010-01-31 03:41 Nobody Note Added: 0001875
2010-02-24 12:57 jpeg Note Added: 0002932
2010-08-05 20:09 xyblor Note Added: 0006870
2010-08-05 21:58 minmay Note Added: 0006871
2010-08-05 23:29 TGW Note Added: 0006874
2013-05-21 18:41 mumra Relationship added child of 0007071
2014-09-10 15:53 wheals Note Added: 0027183
2014-09-10 15:53 wheals Status new => resolved
2014-09-10 15:53 wheals Fixed in Branch => 0.16 development branch
2014-09-10 15:53 wheals Resolution open => done
2014-09-10 15:53 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker