Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006181 [DCSS] Upload: Graphics minor have not tried 2012-09-06 10:27 2014-12-08 07:49
Reporter white_noise View Status public  
Assigned To
Priority normal Resolution done  
Status closed   Product Branch 0.12 ancient branch
Summary 0006181: Water, grass and sand cuts.
Description It is for feature discussed here: https://crawl.develz.org/tavern/viewtopic.php?p=74773#p74773 [^]
If someone want to experiment with it, here's some cuts.
The order is:
shallow water, grass
deep water, sewage
ocean, deep sewage
sand
Additional Information
Tags No tags attached.
Attached Files png file icon cuts.png [^] (142,462 bytes) 2012-09-06 10:27

- Relationships

-  Notes
(0019970)
KiloByte (manager)
2012-09-06 11:30

Sorry, but I think that's a bad idea. It is vital for every square to be obviously water or land, and thus a water square needs to be covered in, let's say, 90%. In these tiles you have water with as little coverage as Note: 0000015% (a wild eyeball guesstimate).
(0019971)
white_noise (reporter)
2012-09-06 11:54
edited on: 2012-09-06 11:54

Have you visited the tavern through link I gave? There is initial idea, a preview and some suggestions. I didn't copied it here because of this link.
Anyway, it is not exact cell tiles. It is pieces from which tiles supposed to be built. I think most of them will cover 90%. Well, maybe some cells will be 85%, but another one can be 105%. In any case it's pretty clear which cell it is, ground or water.

(0019972)
KiloByte (manager)
2012-09-06 12:39

A tile has to be put into the square it is placed on, your example has them displaced by half of a tile's size. This was recently tried with icy stone (with an overflow 2 pixels wide) and it led to minor artefacts in local tiles, bigger breakage in webtiles. Without a significant code overhaul, a tile needs to stay within it boundaries.

It is possible to add overlays to neighbouring tiles, but that adds complexity and information leaks, I doubt it's worth it. Let's keep water from leaking. Also, there's a planned race (djinn) who are hurt by water; tiles you are proposing resemble Slime borders, which may confuse people into thinking standing next to water is bad.
(0019973)
white_noise (reporter)
2012-09-06 12:48

Ok then. It's no big deal. Forget about it, or save it for the better days.

By the way, it may be a good idea if djinn will get hurt a bit while standing next to water. By moist air and splatters. It can serve as warning.
(0028032)
roctavian (developer)
2014-12-08 07:48

Unnecessary and somewhat obsoleted over the years.

- Issue History
Date Modified Username Field Change
2012-09-06 10:27 white_noise New Issue
2012-09-06 10:27 white_noise File Added: cuts.png
2012-09-06 11:30 KiloByte Note Added: 0019970
2012-09-06 11:54 white_noise Note Added: 0019971
2012-09-06 11:54 white_noise Note Edited: 0019971
2012-09-06 12:39 KiloByte Note Added: 0019972
2012-09-06 12:48 white_noise Note Added: 0019973
2013-03-29 06:27 mumra Issue Monitored: mumra
2014-12-08 07:48 roctavian Note Added: 0028032
2014-12-08 07:48 roctavian Status new => closed
2014-12-08 07:49 roctavian Resolution open => done
2014-12-08 07:49 roctavian Fixed in Branch => 0.16 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker