Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006121 [DCSS] Bug Report minor always 2012-08-26 15:30 2015-02-16 21:58
Reporter hasufell View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.14 ancient branch
Summary 0006121: crawl -test crashes on tiles builds
Description ./crawl -test > /dev/null
ASSERT(m_layers[LAYER_TILE_CONTROL].m_regions.size() == 1) in 'tilesdl.cc' at line 195 failed.

Writing crash info to morgue/crash--20120826-152323.txt
ASSERT(m_layers[LAYER_TILE_CONTROL].m_regions.size() == 1) in 'tilesdl.cc' at line 195 failed.

Version: Dungeon Crawl Stone Soup 0.10.3
Platform: unix
Bits: 64
Game mode: normal
Tiles: yes

Command line: ./crawl -test

RC options:
restart_after_game = true


Crash caused by signal 0000006: Aborted

Obtained 13 stack frames.
./crawl(_Z17write_stack_traceP8_IO_FILEi+0x28) [0x549038]: write_stack_trace(_IO_FILE*, int)
./crawl(_Z13do_crash_dumpv+0x2a4) [0x54eac4]: do_crash_dump()
./crawl() [0x5492b4]
/lib64/libc.so.6(+0x32880) [0x7fcd34c28880]:
/lib64/libpthread.so.0(raise+0x2b) [0x7fcd358553ab]:
./crawl() [0x54e339]
./crawl(_Z12AssertFailedPKcS0_ib+0xb5) [0x54e565]: AssertFailed(char const*, char const*, int, bool)
./crawl(_ZN14TilesFramework16update_title_msgESs+0xba) [0xa34aaa]: TilesFramework::update_title_msg(std::string)
./crawl(_Z12startup_stepv+0x40a) [0x96873a]: startup_step()
./crawl() [0x7104b6]
./crawl(main+0x2e9) [0x712279]:
/lib64/libc.so.6(__libc_start_main+0xfd) [0x7fcd34c1528d]:
./crawl() [0x4be619]

Compilation info:
<<<<<<<<<<<
Compiled with GCC 4.5.4 on Aug 26 2012 at 15:23:16
Build platform: x86_64-pc-linux-gnu
Platform: x86_64-pc-linux-gnu
CLFAGS: -O2 -pipe -Wall -Wformat-security -DUSE_TILE -DUSE_TILE_LOCAL -DUSE_SDL -DUSE_GL -DUSE_FT -D_GNU_SOURCE=1 -D_REENTRANT -Wundef -Wno-array-bounds -Wno-parentheses -Wno-unused-parameter -Wwrite-strings -Wshadow -Wuninitialized -Icontrib/install/x86_64-pc-linux-gnu/include -Iutil -I. -I/usr/include -Irltiles -I/usr/include/freetype2 -I/usr/include/SDL -I/usr/include/ncursesw -DWIZARD -DASSERTS -D_GNU_SOURCE=1 -D_REENTRANT -DCLUA_BINDINGS
LDFLAGS: -rdynamic -O2
>>>>>>>>>>>

Place info:
absdepth0 = 0, branch = 0, level_type = 0, type_name =

Level id: D:1
Level id when level was generated: ABSENT
level build method = ABSENT
level layout type = ABSENT

Markers:
<<<<<<<<<<<<<<<<<<<<<<
>>>>>>>>>>>>>>>>>>>>>>

Messages:
<<<<<<<<<<<<<<<<<<<<<<
>>>>>>>>>>>>>>>>>>>>>>

Game state:

mouse_enabled: 0, waiting_for_command: 0, terminal_resized: 0
io_inited: 0, need_save: 0, saving_game: 0, updating_scores: 0:
seen_hups: 0, map_stat_gen: 0, type: 1, arena_suspended: 0

prev_cmd = CMD_NO_CMD
repeat_cmd = CMD_NO_CMD

Player:
{{{{{{{{{{{
Name: []
Species: Yak
Job: Unemployed

class_name:

HP: 0/0; mods: 0/0
MP: 0/0; mods: 0/0
Stats: 0 (0) 0 (0) 0 (0)
Position: (0, 0) <OoB>, god:No God (0), turn_is_over: 0, banished: 0

Skills (mode: auto)
Name | can_train | train | training | level | points | progress
Fighting | | 0 | 0 | 0 | 0 | 0/50
Short Blades | | 0 | 0 | 0 | 0 | 0/50
Long Blades | | 0 | 0 | 0 | 0 | 0/50
Axes | | 0 | 0 | 0 | 0 | 0/50
Maces & Flails | | 0 | 0 | 0 | 0 | 0/50
Polearms | | 0 | 0 | 0 | 0 | 0/50
Staves | | 0 | 0 | 0 | 0 | 0/50
Slings | | 0 | 0 | 0 | 0 | 0/50
Bows | | 0 | 0 | 0 | 0 | 0/50
Crossbows | | 0 | 0 | 0 | 0 | 0/50
Throwing | | 0 | 0 | 0 | 0 | 0/50
Armour | | 0 | 0 | 0 | 0 | 0/50
Dodging | | 0 | 0 | 0 | 0 | 0/50
Stealth | | 0 | 0 | 0 | 0 | 0/40
Stabbing | | 0 | 0 | 0 | 0 | 0/50
Shields | | 0 | 0 | 0 | 0 | 0/50
Traps & Doors | | 0 | 0 | 0 | 0 | 0/50
Unarmed Combat | | 0 | 0 | 0 | 0 | 0/50
Spellcasting | | 0 | 0 | 0 | 0 | 0/65
Conjurations | | 0 | 0 | 0 | 0 | 0/50
Hexes | | 0 | 0 | 0 | 0 | 0/50
Charms | | 0 | 0 | 0 | 0 | 0/50
Summonings | | 0 | 0 | 0 | 0 | 0/50
Necromancy | | 0 | 0 | 0 | 0 | 0/50
Translocations | | 0 | 0 | 0 | 0 | 0/50
Transmutations | | 0 | 0 | 0 | 0 | 0/50
Fire Magic | | 0 | 0 | 0 | 0 | 0/50
Ice Magic | | 0 | 0 | 0 | 0 | 0/50
Air Magic | | 0 | 0 | 0 | 0 | 0/50
Earth Magic | | 0 | 0 | 0 | 0 | 0/50
Poison Magic | | 0 | 0 | 0 | 0 | 0/50
Invocations | | 0 | 0 | 0 | 0 | 0/40
Evocations | | 0 | 0 | 0 | 0 | 0/40

Spell bugs:

Durations:

Attributes:

Mutations:

Demon mutations:

Inventory bugs:

Equipment:

}}}}}}}}}}}


Screenshot:
@

clua stack:


dlua stack:


Lua persistent data:
<<<<<<<<<<<<<<<<<<<<<<
>>>>>>>>>>>>>>>>>>>>>>

Lua marker contents:
<<<<<<<<<<<<<<<<<<<<<<
>>>>>>>>>>>>>>>>>>>>>>
/bin/sh: line 1: 22192 Aborted ./crawl -test > /dev/null
make: *** [test] Error 134
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019732)
hasufell (reporter)
2012-08-26 16:48

compiled without tiles I get

./crawl -test > /dev/null
test error: ....3-nodeps/stone_soup-0.10.3/source/dat/dlua/test.lua:23: No enter_hell created at D:21 (map dumped to level-fail.map)
test error: ...e_soup-0.10.3/source/test/monster-plant-pathfind.lua:52: Monster revisited (40,34); dumped map to monster_plant_pathfind.map
19 tests, 17 succeeded, 2 failed
make: *** [test] Error 1
(0024201)
neil (administrator)
2013-10-16 15:30

Confirmed in 0.14. Retitled
(0028507)
neil (administrator)
2015-02-16 21:58

Looks like this was fixed by the SDL2 port: I can now run a fulldebug local tiles crawl -test without the error. The screen doesn't update very often, but that's normal for -test.

- Issue History
Date Modified Username Field Change
2012-08-26 15:30 hasufell New Issue
2012-08-26 16:48 hasufell Note Added: 0019732
2013-10-16 15:30 neil Note Added: 0024201
2013-10-16 15:30 neil Operating System => Linux
2013-10-16 15:30 neil Console or Tiles => Tiles
2013-10-16 15:30 neil Local or Remote => Local
2013-10-16 15:30 neil Product Branch 0.10 ancient branch => 0.14 development branch
2013-10-16 15:30 neil Product Version 0.10.3 => 0.14-a0-266-g978670c
2013-10-16 15:30 neil Summary make test fails => crawl -test fails on tiles builds
2013-10-16 15:30 neil Status new => confirmed
2013-10-16 15:36 neil Summary crawl -test fails on tiles builds => crawl -test crashes on tiles builds
2015-02-16 21:58 neil Note Added: 0028507
2015-02-16 21:58 neil Status confirmed => resolved
2015-02-16 21:58 neil Fixed in Branch => 0.16 development branch
2015-02-16 21:58 neil Resolution open => done
2015-02-16 21:58 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker