Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006104 [DCSS] Bug Report minor have not tried 2012-08-22 06:41 2018-03-25 05:05
Reporter codrus View Status public  
Assigned To aidanholm
Priority normal Resolution done  
Status resolved   Product Branch 0.12 ancient branch
Summary 0006104: Interlevel travel went upstairs into an exclusion area
Description Attached is a screenshot of me having had used interlevel travel (G) which had me come up those stairs (I'm the 'q), and which were inside an exclusion area.
Additional Information
Tags No tags attached.
Attached Files jpg file icon exclusion_fasttravelbug.jpg [^] (107,670 bytes) 2012-08-22 06:41

- Relationships

-  Notes
(0019666)
neil (administrator)
2012-08-22 15:25
edited on: 2012-08-22 15:26

Were you travelling through one floor or more than one? IIRC, if you use G< or otherwise interlevel travel to an adjacent floor without specifying a location on that floor, your character will take the nearest stair, even if you don't know where it comes out. On the other hand, if you travel across multiple floors or to a particular spot your character will use only known stairs (in an effort to minimise the total distance travelled).

(0019668)
codrus (reporter)
2012-08-22 20:15

More than one floor, the Lair was a few levels above me. This stair may have been my first up, however my memory isn't sure. My commands were "G->l->1" to get to the lair. I /think/ I used that stair from below before manually. So I think it was a used stair.
(0019669)
codrus (reporter)
2012-08-22 21:30

It just did it again! Exact same thing. I was down doing Vaults and did "G->p->1" to run to the Snake Pit and it brought me up that same stair INSIDE the exclusion zone.
(0019671)
codrus (reporter)
2012-08-23 05:15

It occurred to me that it may be because their is a non-exclusion square just to the stair's NW. Maybe the route checker doesn't check the next stair but the next square along the path?
(0019673)
galehar (administrator)
2012-08-23 11:15

Actually, I doubt the travel code has any way to know that the other side of the stairs is going to be in an excluded area. The other level isn't in memory. Maybe the simplest fix would be to exclude the other side of the stairs when setting the exclusion area, but it would still require loading the other level.
(0019681)
jeffqyzt (reporter)
2012-08-23 14:29

RE: setting the far side staircase exclusion - that would also be a potential info leak in the case where you hadn't yet explored the destination level fully.

Could you do it on level load, and only keep the previous level around during the transition? Logic like:

(load destination level)

IF (destination level has an explored staircase)
   AND (connectivity to excluded stair in source level is already established)
   THEN (auto exclude the stair in destination level)
END IF

(unload source level)
(0019688)
codrus (reporter)
2012-08-23 17:41

I must not be understanding, because inter-level travel has always been able to avoid using stairs in exclusions. I'm always using it to exclude dangerous stairs. And if you have all three stairs in inside exclusion zones it won't be able to find a route to travel...
(0032149)
aidanholm (developer)
2018-03-25 05:05

This was fixed at 87dc6a9e9d

- Issue History
Date Modified Username Field Change
2012-08-22 06:41 codrus New Issue
2012-08-22 06:41 codrus File Added: exclusion_fasttravelbug.jpg
2012-08-22 15:25 neil Note Added: 0019666
2012-08-22 15:26 neil Note Edited: 0019666
2012-08-22 20:15 codrus Note Added: 0019668
2012-08-22 21:30 codrus Note Added: 0019669
2012-08-23 05:15 codrus Note Added: 0019671
2012-08-23 11:15 galehar Note Added: 0019673
2012-08-23 14:29 jeffqyzt Note Added: 0019681
2012-08-23 17:41 codrus Note Added: 0019688
2018-03-25 05:05 aidanholm Note Added: 0032149
2018-03-25 05:05 aidanholm Status new => resolved
2018-03-25 05:05 aidanholm Fixed in Branch => 0.21 stable branch
2018-03-25 05:05 aidanholm Resolution open => done
2018-03-25 05:05 aidanholm Assigned To => aidanholm


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker