Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006083 [DCSS] Bug Report major always 2012-08-18 02:02 2013-12-06 03:00
Reporter PhreeStyle View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0006083: ERROR in 'tileweb.cc' at line 200: Socket write error: No buffer space available
Description OSX Mountain Lion Webtiles very nearly works... only it doesn't... :(

Steps to reproduce:

01) sudo easy_install tornado

02) pull latest code

03) submodule update

04) change branch to webtiles-unicode

05) make clean

06) make NO_AUTO_SDK=y SDK_VER=10.8 SDKROOT=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.8.sdk TILES=y WEBTILES=y

07) python webserver/server.py

08) http://localhost:8080/ [^]

09) login

10) start a game

11) *** KABOOM! ***
Additional Information
Tags No tags attached.
Attached Files txt file icon crash-dwg-20120818-003731.txt [^] (6,265 bytes) 2012-08-18 02:02 [Show Content]

- Relationships
child of 0006918closedMedar Fixes for serving webtiles on a Mac 

-  Notes
(0019590)
edlothiol (developer)
2012-08-18 02:11

1. Don't use the webtiles-unicode branch, that's just an older feature testing branch. Just use master.

2. Don't compile with TILES=y, just WEBTILES=y. I have no idea what adding TILES=y will do, but it can't be good.

3. What does sysctl kern.ipc.maxsockbuf say?

(Please be aware that making the Webtiles _server_ run on something other than Linux really isn't a priority for me, though, especially since I don't have an OSX system to test on.)
(0020356)
KiloByte (manager)
2012-10-15 21:25

Reducing severity since it doesn't affect most people, and there's no one with both knowledge of webtiles and access to a Mac.
(0020384)
PhreeStyle (reporter)
2012-10-19 16:20

Ediothiol, thank you for all your help with this.

===== Question 01 =====
01) pull latest code
02) submodule update
03) make clean
04) make NO_AUTO_SDK=y SDK_VER=10.8 SDKROOT=/Applications/Xcode.app/Contents/Developer/Platforms/MacOSX.platform/Developer/SDKs/MacOSX10.8.sdk WEBTILES=y
05) python webserver/server.py
06) http://localhost:8080/ [^] [^]
07) login
08) start a game
09) pick race and character. <we are getting further than before! >
10) Kaboom! :-)

Same error as before. TILES=Y builds and runs fine.


===== Question 03 =====
kern.ipc.maxsockbuf: 4194304
(0022292)
CKyle (reporter)
2013-04-15 04:22

I was having the same issue so I decided to check out the cause.

It turns out I had a different bit of kernel state in my Mountain Lion installation:
net.local.dgram.recvspace: 4096

That setting limited the space available for datagrams from crawl to the webserver, causing a crash every time crawl tried sending a large menu such as the list of commands.
If you feel comfortable doing so, one workaround is to issue the following the command in a console
sudo sysctl -w net.local.dgram.recvspace=12288

where 12288 is some sufficiently large number. I don't know the size of the largest datagram, so I do not know how large a value that setting needs.

If you're fine patching in code, you could try using the patches in https://crawl.develz.org/mantis/view.php?id=6918 [^] . You shouldn't need to use the console command if you use those patches.
(0024607)
Medar (developer)
2013-12-06 03:00

Finally applied CKyle's patches, so this should be fixed in 0.14-a0-1322-g85c66a1.

- Issue History
Date Modified Username Field Change
2012-08-18 02:02 PhreeStyle New Issue
2012-08-18 02:02 PhreeStyle File Added: crash-dwg-20120818-003731.txt
2012-08-18 02:11 edlothiol Note Added: 0019590
2012-10-15 21:25 KiloByte Note Added: 0020356
2012-10-15 21:25 KiloByte Severity block => major
2012-10-19 16:20 PhreeStyle Note Added: 0020384
2013-04-15 04:22 CKyle Note Added: 0022292
2013-04-15 09:08 mumra Relationship added child of 0006918
2013-12-06 03:00 Medar Note Added: 0024607
2013-12-06 03:00 Medar Status new => resolved
2013-12-06 03:00 Medar Fixed in Branch => 0.14 development branch
2013-12-06 03:00 Medar Resolution open => done
2013-12-06 03:00 Medar Assigned To => Medar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker