Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006073 [DCSS] Upload: Graphics minor have not tried 2012-08-15 07:33 2013-07-23 22:46
Reporter white_noise View Status public  
Assigned To ontoclasm
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0006073: Crypt wall/floor tiles
Description Edited version of old crypt tiles.
Additional Information
Tags No tags attached.
Attached Files png file icon crypt_walls.png [^] (21,540 bytes) 2012-08-15 07:33


png file icon crypt_floors.png [^] (6,922 bytes) 2012-08-15 07:33


png file icon crypt-tiles.png [^] (278,504 bytes) 2012-08-16 23:56
png file icon crypt2.png [^] (151,950 bytes) 2012-08-17 09:53
png file icon crypt_doors.png [^] (7,344 bytes) 2012-08-17 09:54


png file icon crypt_walls2.png [^] (21,779 bytes) 2012-08-17 09:55


png file icon crypt_vertical_doors.png [^] (5,625 bytes) 2012-08-24 21:48


png file icon crypt_vertical_doors2.png [^] (5,447 bytes) 2012-08-24 21:51


png file icon crypt_vertical_doors3.png [^] (7,927 bytes) 2012-08-24 22:42

- Relationships

-  Notes
(0019556)
ajg_matebo (reporter)
2012-08-16 09:17

Beautiful. However, it's ridiculous for a Crawl tile to use 2,000+ colors.
(0019557)
white_noise (reporter)
2012-08-16 10:05

Not in my opinion. I believe we should use as many colors as we need if it creates better results. We already have ascetic console version, so I don't think we should restrain ourselves with tiles.
(0019559)
KiloByte (manager)
2012-08-16 10:41

2000 is wrong. A floor/wall tile should use have 4096 colours, minus a few that happen to end up with the exact same value, due to 256-level quantization of R/G/B components.

That Denzi uses a primitive unoptimized 256-colour palette[1] and still manages to draw good tiles doesn't mean everyone should. A good artist can produce decent results with bad tools, a bad artist can produce crap with good tools, but that's not a reason to limit ourselves. The tile format has enough limitations by itself, anything RGB that fits within a 32x32 frame is fair game, so is RGBA for monsters and items.

[1]. If you look at any of his tiles, you can notice every R/G/B component has values divisible by 32.
(0019568)
edlothiol (developer)
2012-08-16 23:56

They're in a branch (crypt-tiles), together with an experiment: I tried making the wall shadows in crypt larger. I may have overdone it, though... See the screenshot.
(0019569)
roctavian (developer)
2012-08-17 01:22

I do like the larger wall shadows, though I also agree it's a bit overdone -- I think it only has the potential to look weird when LOS shadow cuts off sharply in a spot where wall-shadow cuts off sharply, like on the little island of wall to the southwest of the player in the screenshot.

I like these tiles, but I actually think the highlights of the wall tiles should be emphasized a little bit more. I know dd mentioned that before and folks said that it looks fine, but I think it's important for the sake of different monitor settings/other viewing conditions.
(0019573)
ontoclasm (developer)
2012-08-17 06:44
edited on: 2012-08-17 06:51

When I made these initially, I put a line of dark pixels at the top and bottom of the side columns on each wall tile, so that when you have two wall tiles vertically adjacent the columns get separated. white_noise's don't have these, so you get this sort of saucer-shaped thing on the corners of vertical walls, which looks odd to me.

Edit: It's also partly because the heads and bases of those columns are significantly brighter than most of the rest of the tiles, so they make a really noticeable pattern everywhere. They should probably just be the same color as the columns themselves.

(0019574)
ajg_matebo (reporter)
2012-08-17 07:31

A 32x32 tile shouldn't have to use true color. At that level, it would be indistinguishable from paletted.

And Denzi is a great artist because of his disciplined approach, not in spite of it.
(0019577)
white_noise (reporter)
2012-08-17 10:00

I've noticed that door stand out too much and made a crypt door set. It would be cool to use separate sets for different walls. Also little changes has been made to wall tiles. Please, use second variant.

(crypt2.png shouldn't be there. I've uploaded it by mistake.)
(0019709)
edlothiol (developer)
2012-08-24 20:13

I updated the branch.

Considering we've now got vertical large gate tiles (0006105), would you mind making corresponding variants of the your door tiles?
(0019715)
white_noise (reporter)
2012-08-24 21:53
edited on: 2012-08-24 22:44

Done.
Second variant may be better. Or third.

(0023547)
ontoclasm (developer)
2013-07-23 22:46

Finally got around to putting these in. Thanks to white_noise and edlothiol for actually doing all the work!

- Issue History
Date Modified Username Field Change
2012-08-15 07:33 white_noise New Issue
2012-08-15 07:33 white_noise File Added: crypt_walls.png
2012-08-15 07:33 white_noise File Added: crypt_floors.png
2012-08-15 15:56 edlothiol Issue Monitored: edlothiol
2012-08-16 09:17 ajg_matebo Note Added: 0019556
2012-08-16 10:05 white_noise Note Added: 0019557
2012-08-16 10:41 KiloByte Note Added: 0019559
2012-08-16 23:56 edlothiol File Added: crypt-tiles.png
2012-08-16 23:56 edlothiol Note Added: 0019568
2012-08-17 01:22 roctavian Note Added: 0019569
2012-08-17 06:44 ontoclasm Note Added: 0019573
2012-08-17 06:51 ontoclasm Note Edited: 0019573
2012-08-17 07:31 ajg_matebo Note Added: 0019574
2012-08-17 09:53 white_noise File Added: crypt2.png
2012-08-17 09:54 white_noise File Added: crypt_doors.png
2012-08-17 09:55 white_noise File Added: crypt_walls2.png
2012-08-17 10:00 white_noise Note Added: 0019577
2012-08-24 20:13 edlothiol Note Added: 0019709
2012-08-24 21:48 white_noise File Added: crypt_vertical_doors.png
2012-08-24 21:51 white_noise File Added: crypt_vertical_doors2.png
2012-08-24 21:53 white_noise Note Added: 0019715
2012-08-24 22:42 white_noise File Added: crypt_vertical_doors3.png
2012-08-24 22:44 white_noise Note Edited: 0019715
2013-07-23 22:46 ontoclasm Note Added: 0023547
2013-07-23 22:46 ontoclasm Status new => resolved
2013-07-23 22:46 ontoclasm Fixed in Branch => 0.13 development branch
2013-07-23 22:46 ontoclasm Resolution open => done
2013-07-23 22:46 ontoclasm Assigned To => ontoclasm


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker