Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0006014 [DCSS] Bug Report minor always 2012-08-02 07:20 2012-08-03 17:20
Reporter nubinia View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0006014: z?: spell targetting/selection is confused
Description After airstriking some monsters, typing z? gets the following messages in nubinia's game;

 Cast which spell? (? or * to list)
 Really fire through your iron imp?

Typing n cycles through my other summons.

I'll leave the save game for you.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019346)
sgrunt (administrator)
2012-08-02 17:06

Can you point us to the relevant saved game, or at least a log of the game in question, so that we can get a sense of what spells you had at the time that this occurred?

This is going to be related to the changes I recently made to the "monsters in range" code, but I don't know exactly how yet and a cursory attempt to reproduce the bug failed in the absence of any further information.
(0019347)
nubinia (reporter)
2012-08-02 17:40

These are nubinia's spells;


You are not playing in the latest version (4b14f52) available!

[T]ransfer your save to the latest version?
Transferring...: successful!

--- any key to continue ---

Starting Dungeon Crawl Stone Soup 4b14f52...
 Your Spells                       Type                          Failure   Level
 a - Iskenderun's Mystic Blast     Conjuration                   1%          4
 b - Airstrike                     Air                           0%          4
 c - Mephitic Cloud                Conjuration/Poison/Air        0%          3
 d - Call Imp                      Summoning                     0%          2
 e - Deflect Missiles              Charms/Air                    3%          6
 f - Blink                         Translocation                 1%          2
 g - Freezing Cloud                Conjuration/Ice/Air           1%          6
 h - Lightning Bolt                Conjuration/Air               1%          5
 i - Sticky Flame                  Conjuration/Fire              1%          4
 j - Poisonous Cloud               Conjuration/Poison/Air        1%          6
 k - Conjure Flame                 Conjuration/Fire              1%          3
 l - Control Undead                Necromancy                    1%          4
 n - Shadow Creatures              Summoning                     1%          5
(0019348)
sgrunt (administrator)
2012-08-02 18:08

Turns out this was caused by some latent issues in the recently-redone IMB tracer, exposed by the changes to the "visible monsters in range" check. These are addressed in 0.11-a0-3091-g45a1e57.
(0019365)
nubinia (reporter)
2012-08-03 07:22
edited on: 2012-08-03 07:27

Related? Crashed on Meph cloud

Starting Dungeon Crawl Stone Soup 4b14f52...

Starting Dungeon Crawl Stone Soup 84d7231...

ASSERT(max_ex_rad >= min_ex_rad) in 'target.cc' at line 53 failed.
Writing crash info to /crawl-svn/morgue/omil/crash-omil-20120803-051825.txt

(0019376)
sgrunt (administrator)
2012-08-03 17:20

That's a bug (0006025) which has already been fixed, and in any case unrelated to the original bug here.

- Issue History
Date Modified Username Field Change
2012-08-02 07:20 nubinia New Issue
2012-08-02 17:06 sgrunt Note Added: 0019346
2012-08-02 17:40 nubinia Note Added: 0019347
2012-08-02 18:08 sgrunt Note Added: 0019348
2012-08-02 18:08 sgrunt Status new => resolved
2012-08-02 18:08 sgrunt Fixed in Branch => 0.11 development branch
2012-08-02 18:08 sgrunt Resolution open => done
2012-08-02 18:08 sgrunt Assigned To => sgrunt
2012-08-03 07:22 nubinia Note Added: 0019365
2012-08-03 07:27 nubinia Note Edited: 0019365
2012-08-03 17:20 sgrunt Note Added: 0019376


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker