Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005983 [DCSS] Upload: Graphics tweak N/A 2012-07-27 22:33 2014-08-30 18:26
Reporter Bloax View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005983: New Lich Felid & Minotaur tiles
Description The current Lichkitty tile is kind of bleh, so to say. So I decided to make a fancier one.

Honestly, without knowing what it is, I though it was a monkey skeleton.

I also made a Lichtaur tile, because honestly - you got necromutation castable as a minotaur.
Gotta rock the dungeon with something a bit cooler than a normal lich tile, y'know.

And if you're telling me that mutations aren't displayed in lich form - you're a minotaur with necromutation.
That's already reason enough for looking a bit cooler. :p
Additional Information
Tags No tags attached.
Attached Files png file icon Tiles.png [^] (1,794 bytes) 2012-07-27 22:33

- Relationships

-  Notes
(0019266)
edlothiol (developer)
2012-07-27 22:38

The felid looks kind of cool, although felids can't wear robes.

The lichtaur is too tall (32 pixels is the maximum), and I think the horns are too large, compared to the normal minotaur horns.
(0019268)
Bloax (reporter)
2012-07-27 23:40
edited on: 2012-07-27 23:59

Octopodes can't wear robes either. :p

And eh, does it really matter that he's 6 pixels over the limit? (It was kind of intended to make it look more powerful.)
As for the horns thing, I personally about "hate" the way minotaurs, as the race - is in Crawl.

Minotaurs are huge, powerful humanoid beasts with huge horns and potentially stereotypical goat legs! (At least hooves, man.)

Not some silly average human with a bovine head and some cow horns. :(

(0019301)
oiseaux (reporter)
2012-07-30 14:12

The fact that Octopodes can't wear robes doesn't mean that Felids can. Strange logic.

Agreed that the horns are too big; see the player doll w/ horns for a better idea of how this should look.
(0019340)
Bloax (reporter)
2012-08-02 00:17

Well if that's it then there's no point having a specific minotaur tile.

I'm implying that the octopode lich tile is clearly wearing something that looks a lot like a robe.

I know that I suck at drawing robes, and just generally at a resolution like 32x32;
But does the monkey skeleton really fit into the theme better than this one?
(0019343)
roctavian (developer)
2012-08-02 04:34

I will be re-doing all the Lichform tiles at some point in the future -- though naturally that's not with any sense of propriety and you should feel welcome to submit any of your own. I personally feel they should resemble player doll tiles a bit more, if only to make it easier to depict wielded weapons. Though that should be perfectly possible with the current tiles, in any case.

I made the current octopode lich tile as a stand-in. When octopodes were in trunk, they just used the same lich tile as everybody else, IIRC.
(0019345)
Bloax (reporter)
2012-08-02 16:08

I actually made the felid one BECAUSE the current one looks nothing like the player tile.
(0027111)
PleasingFungus (administrator)
2014-08-30 18:26

Lichkitty has been in for a while, lichotaur isn't going anywhere.

- Issue History
Date Modified Username Field Change
2012-07-27 22:33 Bloax New Issue
2012-07-27 22:33 Bloax File Added: Tiles.png
2012-07-27 22:38 edlothiol Note Added: 0019266
2012-07-27 23:40 Bloax Note Added: 0019268
2012-07-27 23:59 Bloax Note Edited: 0019268
2012-07-30 14:12 oiseaux Note Added: 0019301
2012-08-02 00:17 Bloax Note Added: 0019340
2012-08-02 04:34 roctavian Note Added: 0019343
2012-08-02 16:08 Bloax Note Added: 0019345
2014-08-30 18:26 PleasingFungus Note Added: 0027111
2014-08-30 18:26 PleasingFungus Status new => resolved
2014-08-30 18:26 PleasingFungus Fixed in Branch => 0.16 development branch
2014-08-30 18:26 PleasingFungus Resolution open => done
2014-08-30 18:26 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker