Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005945 [DCSS] Patches tweak N/A 2012-07-18 02:28 2014-09-19 02:01
Reporter jvj24601 View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005945: Deviant travel now defaults to yes
Description Per implementable. This is a fairly frequent prompt, and generally the "go through" level is already safe.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Autotravel-through-out-of-range-levels-now-defaults-.patch [^] (979 bytes) 2012-07-18 02:28 [Show Content]

- Relationships

-  Notes
(0022759)
mumra (developer)
2013-05-21 17:30

I don't think this patch should be applied. In a recent example I got this prompt on Orc:3 trying to travel to another bubble of Orc:3 - except the floor it wanted to take me through was Orc:4 presumably because that was the shortest route, however Orc:4 wasn't fully cleared and a bunch of dangerous stuff was there. So I don't think it's particularly safe to default to 'y'.
(0022881)
Medar (developer)
2013-05-27 15:43

I have had the same situation happen. Even outside orc.

Perhaps it would be worth using a route through the level above, even if it isn't the shortest one.
(0027309)
wheals (administrator)
2014-09-19 02:01

It seems to me safe enough; you can always press 'n' still, of course. Added in 0.16-a0-673-ged37a4e.

- Issue History
Date Modified Username Field Change
2012-07-18 02:28 jvj24601 New Issue
2012-07-18 02:28 jvj24601 File Added: 0001-Autotravel-through-out-of-range-levels-now-defaults-.patch
2013-05-21 17:30 mumra Note Added: 0022759
2013-05-27 15:43 Medar Note Added: 0022881
2014-09-19 02:01 wheals Note Added: 0027309
2014-09-19 02:01 wheals Status new => resolved
2014-09-19 02:01 wheals Fixed in Branch => 0.16 development branch
2014-09-19 02:01 wheals Resolution open => done
2014-09-19 02:01 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker