Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005927 [DCSS] Bug Report trivial always 2012-07-13 18:08 2014-06-13 22:40
Reporter XuaXua View Status public  
Assigned To wheals
Priority normal Resolution done  
Status closed   Product Branch 0.16 ancient branch
Summary 0005927: Non-summoned friendlies should use jewelery (may need balancing)
Description I have a tengu merc with some equipment.
I drop a +3 ring of evasion.

'ctrl-t' 'a' (pick up anything)

I walk him over the ring.

He does not pick it up and wear it.

Bad suicidal Tengu Merc!
Additional Information
Tags No tags attached.
Attached Files ? file icon XuaXua.cs [^] (518,025 bytes) 2012-07-13 22:05

- Relationships

-  Notes
(0018986)
XuaXua (reporter)
2012-07-13 18:09

Considering monsters can use jewelery now...
(0018989)
Claws (developer)
2012-07-13 18:14

Considering that summons (yes, including infinitely-present summons like mercenary) are explicitly blocked from using equipment because the Beogh/Yred equipment dance would be even more tedious when you can't rely on equipment-using summons and combined with the tedium of summons and having to directly cart around all of the equipment dropped by said summons would collect into one of the worst interface/tedium messes possible...
(0018990)
XuaXua (reporter)
2012-07-13 18:26

Also of note, cloaks and potions, which monsters can pick up (or at least start with wearing) and use.
(0018992)
Claws (developer)
2012-07-13 18:32

I appreciate ignorance. It makes for good humour.

Actual issue: Mercenary could be specialized to not be a summon and not provide experience like TRJ spawns, rather then ask for a special case for summons themselves (which have very obvious reasons for not *taking* equipment).
(0018993)
XuaXua (reporter)
2012-07-13 18:34
edited on: 2012-07-13 18:36

If they can use evocables, the tengu is wearing an artefact armour with blinking and rage. Monsters drink potions of rage all the time. Wouldn't the tengu want to use the rage effect himself?

"Claws (reporter) 2012-07-13 18:32 I appreciate ignorance. It makes for good humour."

Note: I don't appreciate you being unnecessarily adversarial, considering I didn't refresh the screen between my posts.

(0018994)
XuaXua (reporter)
2012-07-13 19:12

OF ADDITIONAL NOTE:

My mercenary, using 2 artefact items, just died due to a bear.
He leaves behind nothing. As in, all of it went with him instead of dropping into a stash.

Not that I wanted any of it, but that -3 artefact Dragon Armour, the +3 Battleaxe of Freezing (MR), and the javelins he carried should have dropped.
(0018995)
neil (administrator)
2012-07-13 20:35
edited on: 2012-07-13 20:36

Friendly monsters, even non-summons, are currently explicitly blocked from picking up jewellery. This might change in 0.12, at least temporarily, to test the balance.

Regarding the armour and battleaxe: did the mercenary pick up those items, or start with them? The mercenary card is not intended to be a source of equipment, but it shouldn't make already-existing items cease to exist.

(0018997)
XuaXua (reporter)
2012-07-13 22:06
edited on: 2012-07-13 22:06

The merc picked up these items and equipped them.
On his death, they did not fall, there was nothing.
Should have been at least an armour and an axe.
He did not start with these.

I uploaded the file immediately following his death.

(0018998)
neil (administrator)
2012-07-13 22:15
edited on: 2012-07-13 22:20

I verified as well: Mercenaries can in fact lose non-summoned items when poofing. There are other situations where this could happen beyond the Mercenary card; I am filing this as a separate bug report (edit: 0005929).

Leaving this one open for now, in case we do allow friendlies to pick up jewellery in 0.12.

(0018999)
ion_frigate (reporter)
2012-07-14 00:17

Given that the card isn't available in Nemelex decks, is there any reason not to allow it to be a source of equipment/corpses? It's not exactly like people can scum for the decks, and generally what mercenaries would be generated with is hardly worth scumming for anyway.
(0019021)
neil (administrator)
2012-07-14 21:55

It turns out, Mercenaries are supposed to be considered "summoned" for these purposes (they display as "durably summoned"). Summoned monsters don't pick up equipment anymore; and it is according to MarvinPA an oversight that Mercenaries did. This has been changed (0.11-a0-2855-ge55869e) so that durably summoned creatures, including mercenaries but also monsters from god wrath, don't pick up items.

Leaving this bug open because it is still an issue for gifts, slaves, etc.
(0019118)
XuaXua (reporter)
2012-07-18 17:39

Why not treat Mercs identically to Beogh Orcs (some are placed into existence by Beogh) or Bottled Efreet? Those pick up and drop items just fine. It would make sense to arm someone you have to spend hard-earned gold to hire.
(0020380)
DuxOrbis (reporter)
2012-10-19 06:07

I second XuaXua, I was very confused between reports of Mercs picking up items and having a Merc not pick anything up. My hope was to see them
-Be a full fledged monster, to be real Mercs that have been summoned, but not 'summons' per se.
-Level up (as they do now)
-Equip items (as they used to except dropping them on death)

Side note:
If they actually become a decently desirable addition to your team I would argue for more precise UI for ally inventory management. For instance a list of allies that have slots just like the player, the only option is 'drop', each item it has is assigned a letter so you can choose to unequip it of something it deems 'better' when in fact you would prefer it wore something else for the situation.
(0020382)
galehar (administrator)
2012-10-19 13:04

Allies are also prevented from picking up consumables because they are usually much more valuable to the player. The same logic can be applied to jewellery.

Giving more control to the player over his allies equipment can be problematic. We don't want players spending hours fine tuning their allies' stuff, or restuffing all the band when entering a new branch.

I like dpeg's idea of having a gift ability for Beogh. You gift an item to an orc, and he will keep it forever. That could work for jewellery too. Seems like the best compromise to me.
(0026455)
wheals (administrator)
2014-06-11 17:01

The gift item idea was implemented, mercs went back to no pick up.
(0026477)
XuaXua (reporter)
2014-06-13 22:40

not my preferred resolution

- Issue History
Date Modified Username Field Change
2012-07-13 18:08 XuaXua New Issue
2012-07-13 18:09 XuaXua Note Added: 0018986
2012-07-13 18:14 Claws Note Added: 0018989
2012-07-13 18:26 XuaXua Note Added: 0018990
2012-07-13 18:32 Claws Note Added: 0018992
2012-07-13 18:34 XuaXua Note Added: 0018993
2012-07-13 18:35 XuaXua Note Edited: 0018993
2012-07-13 18:35 XuaXua Note Edited: 0018993
2012-07-13 18:36 XuaXua Note Edited: 0018993
2012-07-13 19:12 XuaXua Note Added: 0018994
2012-07-13 20:35 neil Note Added: 0018995
2012-07-13 20:36 neil Note Edited: 0018995
2012-07-13 22:05 XuaXua File Added: XuaXua.cs
2012-07-13 22:06 XuaXua Note Added: 0018997
2012-07-13 22:06 XuaXua Note Edited: 0018997
2012-07-13 22:15 neil Note Added: 0018998
2012-07-13 22:20 neil Note Edited: 0018998
2012-07-13 22:33 neil Status new => confirmed
2012-07-13 22:33 neil Product Branch 0.11 development branch => longterm development (0.12+)
2012-07-13 22:33 neil Summary Mercenaries should use Jewelery => Non-summoned friendlies should use jewelery (may need balancing)
2012-07-14 00:17 ion_frigate Note Added: 0018999
2012-07-14 21:55 neil Note Added: 0019021
2012-07-18 17:39 XuaXua Note Added: 0019118
2012-10-19 06:07 DuxOrbis Note Added: 0020380
2012-10-19 13:04 galehar Note Added: 0020382
2014-06-11 17:01 wheals Note Added: 0026455
2014-06-11 17:01 wheals Status confirmed => resolved
2014-06-11 17:01 wheals Fixed in Branch => 0.15 development branch
2014-06-11 17:01 wheals Resolution open => done
2014-06-11 17:01 wheals Assigned To => wheals
2014-06-13 22:40 XuaXua Note Added: 0026477
2014-06-13 22:40 XuaXua Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker