Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005906 [DCSS] Upload: Graphics trivial N/A 2012-07-10 04:25 2014-10-22 20:25
Reporter roctavian View Status public  
Assigned To
Priority normal Resolution done  
Status closed   Product Branch 0.11 ancient branch
Summary 0005906: New floor, mist, and wisp tiles for Swamp
Description These tiles should be self-explanatory. Please let me know if you have any feedback, as always.
Additional Information
Tags No tags attached.
Attached Files png file icon swamp.scene.png [^] (30,857 bytes) 2012-07-10 04:25


png file icon swamp.floor.png [^] (24,358 bytes) 2012-07-10 04:25


png file icon swamp.wispy.png [^] (1,968 bytes) 2012-07-10 04:25


png file icon swamp.floor.1.png [^] (24,726 bytes) 2012-07-10 05:04


png file icon swamp.floor.2.png [^] (23,759 bytes) 2012-07-10 05:12


png file icon swampedges.png [^] (4,136 bytes) 2012-07-11 10:57


png file icon swampedges.2.png [^] (4,128 bytes) 2012-07-11 10:58


png file icon swampworm.png [^] (5,058 bytes) 2012-07-12 02:10


png file icon newswampedges.png [^] (8,440 bytes) 2012-07-12 04:36


png file icon swamp.wispy2.png [^] (1,439 bytes) 2012-07-23 05:44


png file icon swamp.wispy3.png [^] (1,466 bytes) 2012-07-23 05:45


png file icon wispydemo.png [^] (16,128 bytes) 2012-07-23 05:46


png file icon vapourdemo.png [^] (5,657 bytes) 2012-07-23 11:16


png file icon vapour.png [^] (1,511 bytes) 2012-07-23 11:16

- Relationships

-  Notes
(0018876)
evilmike (developer)
2012-07-10 04:33

I think I prefer the current Swamp floor tile, even though it's uglier in some ways. I think your tile stands out a lot more, since it's green and brown (the old one is just brown). For a floor tile, it's better to be more plain looking, I think.
(0018877)
roctavian (developer)
2012-07-10 04:57
edited on: 2012-07-10 05:04

That's fair! I tried to mute it and could do so more if you think it'd make the tile usable, but I actually thought the same while making these.

edit: added some since it took as much time to make as type my reply

(0018887)
Galefury (updater)
2012-07-10 14:44

Maybe muddy shallow water could be nice in swamp. I haven't looked at the new swamp layout yet, but I guess there is a lot of shallow water?
(0018891)
evilmike (developer)
2012-07-10 20:25
edited on: 2012-07-10 20:26

The later levels of the 0.11 Swamp are somewhat more watery than the old version. The early levels are less watery. It's a very watery branch overall though, same as before. Shallow water is *much* more common than deep water.

Also, the reuploaded floor tiles look a lot better.

(0018897)
roctavian (developer)
2012-07-10 22:59

Thanks! A couple other things: I could easily make some water-bordering-land tiles that go with these, akin to Shoals shores but swampy. Would that be desirable? I have some good ideas for how it could look.

Also, mangroves: I initially thought I wanted to re-do mangrove tiles but they look okay with this tileset as-is. I could make nicer (and more varied) ones, but the water overlay covering the bottom half of the tile would be prohibitive for the visual effect I'd be going for. Can the tiles be rendered without the overlay?
(0018913)
evilmike (developer)
2012-07-11 11:23

"Thanks! A couple other things: I could easily make some water-bordering-land tiles that go with these, akin to Shoals shores but swampy. Would that be desirable?"

If it looks good, sure.

As for mangrove tiles:

(a) The current tile is pretty good, but if you feel like you can improve it, go ahead. It shouldn't be high priority though. Note that while the feature was renamed, the tile wasn't! It's always been mangrove.png.

(b) Keep the shallow water effect, imo. Mangroves grow in water, and besides that, the water conveys the fact that if you destroy these trees, there is water beneath them.

(c) Make sure whatever tile you make conveys that these trees are thick and hard to see past. Real-life mangroves tend to have roots everywhere and are impossible to see through. Same goes with the ones in Crawl.
(0018916)
edlothiol (developer)
2012-07-11 13:11

We can render the mangroves without the water effect if you show the water otherwise, though.
(0018918)
edlothiol (developer)
2012-07-11 14:03

I think it would be better to draw water borders on the floor tiles, not the other way around (like with the border tiles you made). Otherwise, the borders look weird with mangroves, for example; also, that's how it's already done in Shoals.
(0018927)
roctavian (developer)
2012-07-11 21:54
edited on: 2012-07-12 02:11

The mangroves will definitely show up later, since I'll be revising the water borders here and the tiles for slime first. Removing the overlay is just so I can depict the mangrove emerging from the water slightly lower on the tile (by maybe 8 pixels or so) so I can add more thick root stuff, actually.

Any thoughts on the mist/wisps, while we're at it? Thanks for all the feedback as always.

edit: the effect that I'm using on the swamp worm here is essentially what I'll use on mangroves. I also made new leech tiles, with and without teeth.

(0018940)
roctavian (developer)
2012-07-12 04:40

New water borders that go over land, for deep and shallow water alike. These actually go well with any "natural" floor tiles, and thus could be used in Lair and Spider if anyone likes.
(0018980)
moohaus (reporter)
2012-07-13 15:59

I think these wisps are a bit TOO insubstantial.
(0019172)
roctavian (developer)
2012-07-23 05:47
edited on: 2012-07-23 05:48

Several progressively bolder wisp tiles.

Edit: I was thinking the clouds of thin mist could also work for that one cloud mage wizlab.

(0019176)
evilmike (developer)
2012-07-23 10:00

Since you're doing monsters, one that could really use a new tile is Vapours. The current Vapour tile looks like it took about 15 seconds to make.
(0027537)
roctavian (developer)
2014-10-22 20:25

Ancient unnecessary tiles.

- Issue History
Date Modified Username Field Change
2012-07-10 04:25 roctavian New Issue
2012-07-10 04:25 roctavian File Added: swamp.scene.png
2012-07-10 04:25 roctavian File Added: swamp.floor.png
2012-07-10 04:25 roctavian File Added: swamp.wispy.png
2012-07-10 04:33 evilmike Note Added: 0018876
2012-07-10 04:57 roctavian Note Added: 0018877
2012-07-10 05:04 roctavian Note Edited: 0018877
2012-07-10 05:04 roctavian File Added: swamp.floor.1.png
2012-07-10 05:12 roctavian File Added: swamp.floor.2.png
2012-07-10 13:21 edlothiol Issue Monitored: edlothiol
2012-07-10 14:44 Galefury Note Added: 0018887
2012-07-10 20:25 evilmike Note Added: 0018891
2012-07-10 20:25 evilmike Note Edited: 0018891
2012-07-10 20:26 evilmike Note Edited: 0018891
2012-07-10 22:59 roctavian Note Added: 0018897
2012-07-11 10:57 roctavian File Added: swampedges.png
2012-07-11 10:58 roctavian File Added: swampedges.2.png
2012-07-11 11:23 evilmike Note Added: 0018913
2012-07-11 13:11 edlothiol Note Added: 0018916
2012-07-11 14:03 edlothiol Note Added: 0018918
2012-07-11 21:54 roctavian Note Added: 0018927
2012-07-12 02:10 roctavian File Added: swampworm.png
2012-07-12 02:11 roctavian Note Edited: 0018927
2012-07-12 04:36 roctavian File Added: newswampedges.png
2012-07-12 04:40 roctavian Note Added: 0018940
2012-07-13 15:59 moohaus Note Added: 0018980
2012-07-23 05:44 roctavian File Added: swamp.wispy2.png
2012-07-23 05:45 roctavian File Added: swamp.wispy3.png
2012-07-23 05:46 roctavian File Added: wispydemo.png
2012-07-23 05:47 roctavian Note Added: 0019172
2012-07-23 05:48 roctavian Note Edited: 0019172
2012-07-23 10:00 evilmike Note Added: 0019176
2012-07-23 11:16 roctavian File Added: vapourdemo.png
2012-07-23 11:16 roctavian File Added: vapour.png
2013-03-27 07:34 mumra Issue Monitored: mumra
2014-10-22 20:25 roctavian Note Added: 0027537
2014-10-22 20:25 roctavian Status new => closed
2014-10-22 20:25 roctavian Resolution open => done
2014-10-22 20:25 roctavian Fixed in Branch => 0.16 development branch


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker