Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005863 [DCSS] Bug Report minor have not tried 2012-07-03 21:08 2014-07-15 03:16
Reporter moxian View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005863: Jessica spawned in an unreachable area
Description I don't know what can I say apart from that I think it shouldn't happen.
Attaching screenshot and savefile.
Additional Information
Tags No tags attached.
Attached Files png file icon jessica.png [^] (70,341 bytes) 2012-07-03 21:08


? file icon Doka.cs [^] (124,274 bytes) 2012-07-03 21:09

- Relationships
related to 0005786new Want more connectivity checking for vaults 

-  Notes
(0018686)
neil (administrator)
2012-07-03 22:39
edited on: 2012-07-03 22:40

This is because the unique vaults have the can_overwrite tag, which allows them to be placed on top of existing vaults. Perhaps the can_overwrite code (maps.cc:382-391, in _map_safe_vault_place()) could refuse to overwrite cells with no_monster_gen, but that seems kind of hackish and doesn't make sense for other can_overwrite vaults that aren't intended to place monsters. Perhaps better would be another mask flag, no_overwrite, to specify that a map or cell should not be overwritten even by vaults with can_overwrite.

(0026755)
neil (administrator)
2014-07-15 03:16

This should be fixed as of 0.15-a0-1773-g80c2592, thanks!

- Issue History
Date Modified Username Field Change
2012-07-03 21:08 moxian New Issue
2012-07-03 21:08 moxian File Added: jessica.png
2012-07-03 21:09 moxian File Added: Doka.cs
2012-07-03 22:39 neil Note Added: 0018686
2012-07-03 22:40 neil Note Edited: 0018686
2012-07-04 01:01 neil Relationship added related to 0005786
2014-07-15 03:16 neil Note Added: 0026755
2014-07-15 03:16 neil Status new => resolved
2014-07-15 03:16 neil Fixed in Branch => 0.15 development branch
2014-07-15 03:16 neil Resolution open => done
2014-07-15 03:16 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker