Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005861 [DCSS] Bug Report minor always 2012-07-03 05:42 2014-01-30 07:13
Reporter josh View Status public  
Assigned To Medar
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005861: Elemental staves depend on Evocations, but don't allow training it
Description The formulas for extra damage from elemental staves (chance of extra damage and amount of extra damage) depend on Evocations skill. However, having or wielding an elemental staff does not enable Evocations for training, the way a wand or other evocable item does.
Additional Information
Tags patch
Attached Files ? file icon 0001-Let-elemental-staves-enable-training-Evocations.patch [^] (1,747 bytes) 2013-08-15 20:31 [Show Content]
? file icon 0001-Don-t-let-unknown-staves-allow-training-Evocations.patch [^] (1,406 bytes) 2013-10-01 20:45 [Show Content]

- Relationships
has duplicate 0007470closedneil Cannot train Evo with only staff of earth 

-  Notes
(0018680)
galehar (administrator)
2012-07-03 10:35

Well elemental staves aren't "evokable". In the old system, you couldn't victory dance evocations with an elemental staff, so I kept it that way. Seems to be more consistent and it's hardly a significant limitation given the sheer number of items which allows training evocations.
(0018682)
josh (reporter)
2012-07-03 16:57

It seems both inconsistent and non-obvious to have to carry around a separate evocable item just to train Evocations for the staff. This did come up for me in a recent game: I had a staff of fire but could not train Evocations to use it effectively.

Either carrying an elemental staff should allow training Evocations, or using one effectively should depend on a different skill that the staff allows training of.
(0022891)
mumra (developer)
2013-05-27 19:22

The fact that they depend on evocations kind of implies that your character is evoking them automatically whilst hitting things. So I'd agree with josh and say they should allow training. Since it's trivial to just carry an extra evokable item I'd say there is no balance-breaking reason why we can't just let the staves themselves allow Evo training.
(0023756)
BlackSheep (reporter)
2013-08-15 19:37
edited on: 2013-08-15 20:31

Oddly, you can train evocations if your staff is unidentified.

Edit: I created a patch that checks if a staff uses evocations and enables training if so. I did not change un-ID'd staves allowing evo, and didn't put in any fancy checks for cursed status or swapability.

(0024122)
BlackSheep (reporter)
2013-10-01 20:45

Second patch (apply them consecutively) prevents unknown staves allowing you to train Evocations.
(0025071)
karphead (reporter)
2014-01-24 20:07

Was BlackSheep's patch ever implemented? Playing trunk yesterday and I found the Elemental Staff on D:3 yesterday and Evocations did not show up as trainable.
(0025138)
Medar (developer)
2014-01-30 07:13

Patches are in as a squashed commit: 0.14-a0-2341-gc799e94

Thanks a lot!

Next commit adds the Elemental Staff.

Sorry that this wasn't applied sooner. Poking people in ##crawl-dev on FreeNode might help in cases where patches seem to be forgotten about.

- Issue History
Date Modified Username Field Change
2012-07-03 05:42 josh New Issue
2012-07-03 10:35 galehar Note Added: 0018680
2012-07-03 16:57 josh Note Added: 0018682
2013-05-27 19:22 mumra Note Added: 0022891
2013-08-15 18:50 neil Relationship added has duplicate 0007470
2013-08-15 18:52 neil Relationship replaced duplicate of 0007470
2013-08-15 18:53 neil Relationship replaced has duplicate 0007470
2013-08-15 19:37 BlackSheep Note Added: 0023756
2013-08-15 20:31 BlackSheep Note Edited: 0023756
2013-08-15 20:31 BlackSheep File Added: 0001-Let-elemental-staves-enable-training-Evocations.patch
2013-08-15 20:32 BlackSheep Tag Attached: patch
2013-09-25 15:23 BlackSheep Issue Monitored: BlackSheep
2013-10-01 20:45 BlackSheep File Added: 0001-Don-t-let-unknown-staves-allow-training-Evocations.patch
2013-10-01 20:45 BlackSheep Note Added: 0024122
2014-01-24 20:07 karphead Note Added: 0025071
2014-01-30 07:13 Medar Note Added: 0025138
2014-01-30 07:13 Medar Status new => resolved
2014-01-30 07:13 Medar Fixed in Branch => 0.14 development branch
2014-01-30 07:13 Medar Resolution open => done
2014-01-30 07:13 Medar Assigned To => Medar


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker