Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005781 [DCSS] Bug Report minor always 2012-06-16 02:15 2015-08-17 17:57
Reporter crate View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status closed   Product Branch 0.11 ancient branch
Summary 0005781: Saving the game with 128+ MP leads to negative MP on load
Description As the description says. I got this in wizmode while messing around to see what the max possible MP was. This will probably never come up in a real game though.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0018423)
crate (reporter)
2012-06-16 02:17

I should probably also mention that maxmp is saved just fine, it is just that you will have negative current mp when you load.
(0018476)
KiloByte (manager)
2012-06-19 12:29

How is that even possible? A deep elf with all skills at 27, high mp 3, staff of power and two rings of magical power has 77 maxmp, an octopode with eight rings -- 112.
(0018477)
ion_frigate (reporter)
2012-06-19 13:31
edited on: 2012-06-19 13:41

Don't forget the Hat of Pondering, wearable by both. Still though, it doesn't seem like it'd be enough. Does wizard mode let you create artefacts with +MP on them?

And certainly it'd be relevant, for example, if any shields or amulets with +MP are introduced at some point. You'd only need a total of 15 from those to get over 128 MP with the octopode. Marginal, but still possibly relevant.

(0018480)
crate (reporter)
2012-06-19 15:05

+30% MP mutation, hat of pondering, 8 mp rings, staff of power, divine vigour with 27 invo. You get to 154 MP or something. Like I said this is extremely unlikely to occur in an actual game.
(0018481)
KiloByte (manager)
2012-06-19 15:46

Hrm, the +MP artefact property has misleading names in the source. It can be set with &t to any value, though, so there's no limit on maxmp you can get in wizmode.

In real games, it's Divine Vigour what's the main offender. You don't even need the mutation, hat or staff: an octopode with eight rings is enough. So I guess the field needs to be extended.
(0027100)
PleasingFungus (administrator)
2014-08-29 03:38

Turns out you didn't even need to extend the field; just using an unsigned byte gets you more than enough space to handle the highest MP I could manage in practice.

If needed, it wouldn't be hard to extend the field (I actually implemented that fix first!), but it'd require a minor tag - no need to go through the hassle for now.

- Issue History
Date Modified Username Field Change
2012-06-16 02:15 crate New Issue
2012-06-16 02:17 crate Note Added: 0018423
2012-06-19 12:29 KiloByte Note Added: 0018476
2012-06-19 13:31 ion_frigate Note Added: 0018477
2012-06-19 13:41 ion_frigate Note Edited: 0018477
2012-06-19 15:05 crate Note Added: 0018480
2012-06-19 15:46 KiloByte Note Added: 0018481
2013-05-26 02:10 mumra Issue Monitored: mumra
2014-08-29 03:38 PleasingFungus Note Added: 0027100
2014-08-29 03:38 PleasingFungus Status new => resolved
2014-08-29 03:38 PleasingFungus Fixed in Branch => 0.16 development branch
2014-08-29 03:38 PleasingFungus Resolution open => done
2014-08-29 03:38 PleasingFungus Assigned To => PleasingFungus
2015-08-17 17:57 crate Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker