Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005772 [DCSS] Bug Report minor have not tried 2012-06-14 00:54 2012-06-26 19:58
Reporter ortoslon View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005772: no autopickup for clean chunks
Description savefile attached
Additional Information
Tags No tags attached.
Attached Files ? file icon Ortoslon.cs [^] (464,846 bytes) 2012-06-14 00:54

- Relationships
has duplicate 0005758closed I'm not autolooting chunks, anymore. 
has duplicate 0005798resolvedneil Autopickup duplicate amulet 
has duplicate 0005837closedneil I stopped autopickuping chunks 
child of 0004238resolvedneil In-game selection of auto-pickup items 

-  Notes
(0018411)
neil (administrator)
2012-06-14 17:05
edited on: 2012-06-14 17:08

This happens when you first encounter a chunk which an autopickup_exception says not to pick up. This results in "chunks" being turned off in the force_autopickup table... but it doesn't show up in the menu because it's not supposed to be toggled. Something similar happens for other autopickup_exceptions (for example, if you have an exception to pick up curare, and you encounter a needle of curare before any other needle and before using the \ menu, autopickup will be turned on for all needles).

The solution is to not set force_autopickup[][] from the options, but rather only from explicit action in the \ menu. This will happen, but is currently waiting on a three-state menu, to allow setting items to "defer to options" rather than just "force on" and "force off".

Edit: When this is fixed, everyone's force_autopickup[][] will be reset to the default, since we currently have no way to tell what was manually set and what was a (potentially incorrect) inference from the options.

(0018587)
neil (administrator)
2012-06-26 19:58

Fixed in trunk: 0.11-a0-2475-gf4a2850 prevents it from happening again, and 0.11-a0-2478-g65644f0 resets everyone's force_autopickup table.

- Issue History
Date Modified Username Field Change
2012-06-14 00:54 ortoslon New Issue
2012-06-14 00:54 ortoslon File Added: Ortoslon.cs
2012-06-14 00:54 ortoslon Issue Monitored: ortoslon
2012-06-14 17:05 neil Note Added: 0018411
2012-06-14 17:05 neil Status new => confirmed
2012-06-14 17:06 neil Relationship added child of 0004238
2012-06-14 17:08 neil Note Edited: 0018411
2012-06-15 01:07 Thann Issue Monitored: Thann
2012-06-15 01:54 neil Relationship added has duplicate 0005758
2012-06-19 00:48 neil Relationship added has duplicate 0005798
2012-06-26 18:10 neil Relationship added has duplicate 0005837
2012-06-26 19:58 neil Note Added: 0018587
2012-06-26 19:58 neil Status confirmed => resolved
2012-06-26 19:58 neil Fixed in Branch => 0.11 development branch
2012-06-26 19:58 neil Resolution open => done
2012-06-26 19:58 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker