Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005734 [DCSS] Bug Report minor always 2012-06-05 21:29 2014-07-12 06:05
Reporter Chthon View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0005734: Chain sleep is not fun
Description Aizur casts a spell.
You fall asleep.
Aizur casts a spell.
The poison arrow hits you.
You wake up.
Aizur casts a spell.
You fall asleep.
Aizur casts a spell.
The poison arrow hits you.
You wake up.
Aizur casts a spell.
You fall asleep.
... goes on for a while.

While I'm not asking for fairness, fair would be that the player gets the same sleep immunity after waking up that monsters do, not having any cooldown at all is not fun in the slightest.

Earlier I was greeted with the messages that you see above. He put me to sleep at least 4 times in a row (I had to hit -more- quite a few times as well) however I never got to do anything during this time. Admittedly a little MR was in order here, but sleep should not be as bad as paralysis in any case. Now I initiated this fight, but this could have very easily been me moving around a corner and him getting the first shot.

If anything the player should be able to take at least 1 turn after waking up before he can be put back to sleep, assuming he survived. Anything less results in the player just watching helplessly as he's nickled and dimed to death. Giving any longer period of time really is not necessary as it is long enough to equip MR to avoid it again.

I ask this in the spirit that every game should be winnable, no matter how much the deck is stacked against the player, otherwise it just encourages start scumming until you get lucky. Encounters like this one can end up a showstopper, not because of a player mistake, but just pure happenstance. In short, a player should dig his own grave, not find out it's already been dug before he started.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0019767)
ludamad (reporter)
2012-08-28 22:11

I fully agree with this. My deaths that occur due to chain paralysis/sleep are the few where I really curse luck and not just my own idiocy, which is A Bad Thing.
(0019771)
Isabel (reporter)
2012-08-29 17:38

Agreed, I just died to a normal lich because it kept paralyzing. Over. And Over. And Over...
(0026736)
PleasingFungus (administrator)
2014-07-12 06:05

Temporary immunity to repeated paralysis & sleep have been a thing for quite a while. (57d621c9d042, 18 months before this ticket was opened, and 71cfae93f, a year afterward... respectively.) Neither were communicated well to the player, at the time, however.

That's been fixed (as of 2867f71d and 0f135746da2f respectively), so... all good!

- Issue History
Date Modified Username Field Change
2012-06-05 21:29 Chthon New Issue
2012-08-28 22:11 ludamad Note Added: 0019767
2012-08-29 17:38 Isabel Note Added: 0019771
2014-07-12 06:05 PleasingFungus Note Added: 0026736
2014-07-12 06:05 PleasingFungus Status new => resolved
2014-07-12 06:05 PleasingFungus Fixed in Branch => 0.15 development branch
2014-07-12 06:05 PleasingFungus Resolution open => done
2014-07-12 06:05 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker