Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005722 [DCSS] Bug Report minor always 2012-06-04 01:48 2013-03-30 22:50
Reporter smock View Status public  
Assigned To galehar
Priority normal Resolution done  
Status closed   Product Branch 0.11 ancient branch
Summary 0005722: Nagas cannot constrict stone giants but can constrict stone giant skeletons
Description Nagas cannot constrict stone giants but can constrict stone giant skeletons... for example. As far as I can tell, this happens with all largeish creatures and their undead versions.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0018221)
neil (administrator)
2012-06-04 22:48

Skeletons (and zombies) have only two sizes: small and large. Stone giants are SIZE_HUGE (two steps up from large), but their zombies are SIZE_LARGE (the same as a naga for constriction purposes). The same (or reverse) problem occurs on the lower end: a boggart is SIZE_LITTLE, but its zombie is one category larger at SIZE_SMALL (and thus could not be constricted by a hypothetical little constrictor).

One fix might be to set the zombie's body size (not its ZOMBIE_SMALL/ZOMBIE_LARGE zombie type) from the base monster. I'm not sure what side effects this would have beyond constriction and weapon choice, though.
(0018223)
galehar (administrator)
2012-06-05 01:13

what's the purpose of zombie small/large anyway? Can't it be a template or something? Same for skeletons and co
I guess it's because of the glyph, but we can keep it the same and still have a more flexible design.
(0018227)
KiloByte (manager)
2012-06-05 02:02

Until quite recently, there was no way to change a monster's glyph without a separate MONS_ enum, that's why we had separate mimics for every item type, etc. Nowadays, we can use the same code as for new mimics or merged slime creatures.
(0020364)
galehar (administrator)
2012-10-16 14:32

Fixed in 0.12-a0-840-gbfa4146
Thanks for the report

- Issue History
Date Modified Username Field Change
2012-06-04 01:48 smock New Issue
2012-06-04 22:48 neil Note Added: 0018221
2012-06-05 01:13 galehar Note Added: 0018223
2012-06-05 02:02 KiloByte Note Added: 0018227
2012-10-16 14:32 galehar Note Added: 0020364
2012-10-16 14:32 galehar Status new => resolved
2012-10-16 14:32 galehar Fixed in Branch => 0.12 development branch
2012-10-16 14:32 galehar Resolution open => done
2012-10-16 14:32 galehar Assigned To => galehar
2013-03-30 22:49 smock Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker