Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005693 [DCSS] Upload: Maps and Vaults minor have not tried 2012-05-22 05:23 2012-06-03 11:46
Reporter Zannick View Status public  
Assigned To evilmike
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005693: Zot portal mimics
Description This patch adds vaults such that:
- the traditional three ordinary portals variant has a 1/6 chance of a fourth portal which is a mimic
- an appearance by what appears to be zot_entry_small has an approximate 1/6 chance of actually being a mimic instead (with the real portal behind a secret door).
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Add-some-Zot-portal-mimics.patch [^] (1,715 bytes) 2012-05-22 05:23 [Show Content]
? file icon 0001-Add-a-Zot-portal-mimic.patch [^] (1,265 bytes) 2012-05-26 20:16 [Show Content]

- Relationships

-  Notes
(0018117)
elliptic (developer)
2012-05-22 05:27

That sort of vault with a portal or branch entrance behind a secret door just causes people to submit bug reports... not good. I like the mimic entrance idea, but that secret door in zot_entry_small_mimic doesn't work... what about replacing it with a real door and adding a second door to zot_entry_small?
(0018120)
st (reporter)
2012-05-22 15:44

are mimics not played out enough yet
(0018122)
Zannick (reporter)
2012-05-22 17:34

I don't really want to mess with the simplicity of zot_entry_small by adding a door... :/
Let me fool around with lua for a bit to see if I can make it reveal the door when the mimic is revealed.
(0018145)
Zannick (reporter)
2012-05-26 20:20
edited on: 2012-05-26 20:21

After some hacking around with Lua and some thought, I decided just to remove the fake zot_entry_small and go with just the basic one for now.

The new file "0001-Add-a-Zot-portal-mimic.patch" is the patch that should be used.

(0018199)
evilmike (developer)
2012-06-03 10:18

Patch applied, thanks.

I also have concerns that mimics are becoming overused, but I'm accepting this because it's only a 1/6 chance in a single vault. Also, we already have portal mimics and such... this patch just lets them get used for Zot as well.
(0018201)
KiloByte (manager)
2012-06-03 11:46

1/6 of all the time a branch entry (ie, mandatory) vault spawns is A LOT. Also, with mimics being as overpowered as they are currently, it will lead to people scumming summons every time they see it.

I'd instead use the regular chance of portals being mimics, ie, 1/100.

- Issue History
Date Modified Username Field Change
2012-05-22 05:23 Zannick New Issue
2012-05-22 05:23 Zannick File Added: 0001-Add-some-Zot-portal-mimics.patch
2012-05-22 05:27 elliptic Note Added: 0018117
2012-05-22 15:44 st Note Added: 0018120
2012-05-22 17:34 Zannick Note Added: 0018122
2012-05-26 20:16 Zannick File Added: 0001-Add-a-Zot-portal-mimic.patch
2012-05-26 20:20 Zannick Note Added: 0018145
2012-05-26 20:21 Zannick Note Edited: 0018145
2012-06-03 10:18 evilmike Note Added: 0018199
2012-06-03 10:18 evilmike Status new => resolved
2012-06-03 10:18 evilmike Fixed in Branch => 0.11 development branch
2012-06-03 10:18 evilmike Resolution open => done
2012-06-03 10:18 evilmike Assigned To => evilmike
2012-06-03 11:46 KiloByte Note Added: 0018201


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker