Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005658 [DCSS] Bug Report minor always 2012-05-10 06:19 2014-11-17 04:16
Reporter Tenaya View Status public  
Assigned To PleasingFungus
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0005658: Holy beings will not cross holy fire
Description I was on the Pandemonium Holy level and observed strange behavior.
All of the holy beings (angels, daevas, ophons, paladins, life-yaks, etc.) on that level (except for phoenix and pearl dragons, I think)are unwilling to walk through the holy fire clouds cast by ophons, but are willing to walk through my Conjure Flame clouds. I don't know what the damage comparison is, but I figured that since the holy fire was only doing 10 or so damage to me (with rF) for stepping through them, that they should have been willing to brave the damage if they were willing to pass through my flame clouds.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0008937closedPleasingFungus Undead and negative clouds 

-  Notes
(0018036)
evilmike (developer)
2012-05-10 09:09

They're undamaged by holy flames, which is why this behaviour is silly. In my opinion, melee holies should ignore holy flames.

I think daevas, cherubs and ophans shouldn't cross them... this way when you are surrounded by holy flames from an ophan, these ranged enemies will hang back and hit you with ranged attacks. Other enemies (angels, apis, etc) shouldn't be afraid to wade through the clouds though.
(0018037)
KiloByte (manager)
2012-05-10 09:26

If I recall correctly, the reason is that holies who can shoot holy fire also have a ranged attack, and the "trapped in a ring of flames" thing would be totally broken if enemies flocked on you anyway, making you lose no time or hp.

So, if there's an ophan around, it's no error if melee ones fall back as well.
(0018039)
Tenaya (reporter)
2012-05-10 18:33

Okay, I did suspect that they would take 0 damage from holy fire, but I was unsure because of their unwillingness to pass through it.
The reason it seemed strange to me though was because I was playing a ranged caster so it gave me a chance to recover Magic Points.
Also, and sorry for not remembering, I think they would not give chase if I escaped from the ring and left them behind.

I can understand some of the tactics and reasoning, but all in all, the behaviour did not benefit them.
(0027780)
PleasingFungus (administrator)
2014-11-17 04:16

This should be fixed now.

- Issue History
Date Modified Username Field Change
2012-05-10 06:19 Tenaya New Issue
2012-05-10 09:09 evilmike Note Added: 0018036
2012-05-10 09:26 KiloByte Note Added: 0018037
2012-05-10 18:33 Tenaya Note Added: 0018039
2014-09-07 17:24 PleasingFungus Relationship added related to 0008937
2014-11-17 04:16 PleasingFungus Note Added: 0027780
2014-11-17 04:16 PleasingFungus Status new => resolved
2014-11-17 04:16 PleasingFungus Fixed in Branch => 0.16 development branch
2014-11-17 04:16 PleasingFungus Resolution open => done
2014-11-17 04:16 PleasingFungus Assigned To => PleasingFungus


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker