Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005653 [DCSS] Bug Report crash always 2012-05-08 10:37 2015-02-24 17:32
Reporter nicolae View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005653: Crash when a dual-wielding monster attacks with a reaching weapon if their other weapon isn't reaching.
Description I was messing around with giving dual-wielding monsters reaching weapons, for vault reasons, and discovered that if one weapon is reaching, but the other isn't, when they attack with the reaching weapon, it sometimes crashes with an assert:

ASSERT(attk_flavour == AF_REACH || weapon && weapon_reach(*weapon)) in 'melee_attack.cc' at line 4029 failed.

This doesn't happen if the monster is dual-wielding two reaching weapons. It also seems like it only happens when the reaching attack successfully hits and does damage, since the line in question deals with printing "hits you from afar!"

I don't know if this happens with other brands.
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0018002)
KiloByte (manager)
2012-05-08 10:44

Quite hard to explain this theme-wise, and existing two-weaponing monsters have a precaution against this.

I'm pondering simply hard forbidding reaching with two weapons.
(0018003)
nicolae (reporter)
2012-05-08 10:53

That might be for the best, or else you're likely to end up with a vault where a two-headed ogre stands on the other side of deep water and double-bonks you with two giant spiked clubs.
(0028559)
wheals (administrator)
2015-02-24 17:32

The assert hasn't been happening for a while, but the monster was able to reach with its offhand weapon even if it was not reaching. That should be fixed in 0.16-a0-4093-g160c580.

- Issue History
Date Modified Username Field Change
2012-05-08 10:37 nicolae New Issue
2012-05-08 10:44 KiloByte Note Added: 0018002
2012-05-08 10:53 nicolae Note Added: 0018003
2013-05-26 06:06 mumra Issue Monitored: mumra
2015-02-24 17:32 wheals Note Added: 0028559
2015-02-24 17:32 wheals Status new => resolved
2015-02-24 17:32 wheals Fixed in Branch => 0.16 development branch
2015-02-24 17:32 wheals Resolution open => done
2015-02-24 17:32 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker