Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005624 [DCSS] Bug Report minor always 2012-05-02 05:14 2013-03-10 22:43
Reporter evilmike View Status public  
Assigned To Kate
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005624: Boulder beetles interact strangely with water and lava
Description If a boulder beetle begins rolling, it can pass through water and lava. If it stops rolling (such as by hitting you), it will still be in the lava/water, unharmed, and will attack you normally.

This gets really weird if you confuse it. The boulder beetle in lava will move to another square of lava, and burn up.
Additional Information
Tags No tags attached.
Attached Files ? file icon 0001-Fix-strange-interaction-of-boulder-beetles-and-fluid.patch [^] (1,596 bytes) 2013-03-01 12:38 [Show Content]

- Relationships
has duplicate 0006259closed Boulder Beetle rolled over deep water, did weird things before drowning. 

-  Notes
(0017944)
mageykun (reporter)
2012-05-02 07:04

Well, arguably, skimming over water / lava could be an intentional feature (hydroplaning and... lavaplaing?). But the rest of weirdness, definitely not.
(0017945)
evilmike (developer)
2012-05-02 07:07

In that case, there is still a problem: in tiles, the beetle is depicted as *in* the lava.
(0021211)
mumra (developer)
2013-03-01 12:43

Attached patch stops boulder beetles from rolling over any liquids. This seems like the best option as "skimming" raises all kinds of questions and edge cases.

I was perhaps overly cautious with the condition checked, it could be relaxed to (feat_is_water || feat_is_lava), but the way I did it feels more future proof.
(0021216)
mumra (developer)
2013-03-01 15:21

On further thought - maybe for shallow water "screech to a halt" is a bit strange. They could either just keep on going, or land in the water with a splash and stop rolling. Will wait for feedback on this. The current patch is still probably better than the status quo.
(0021313)
reid (reporter)
2013-03-08 23:20

I'd think the best option would be to have boulder beetles die if they roll into deep water or lava ("The boulder beetle sinks like a stone."). That's what I would expect to happen physically, and it wouldn't exactly be a game-breaking abuse to be able to kill boulder beetles by setting it up so they roll into lava.

For shallow water I think landing in the water with a splash and stop rolling is best. Probably they shouldn't be able to start rolling when in shallow water either.
(0021347)
Kate (developer)
2013-03-10 22:38
edited on: 2013-03-10 22:43

I pushed the patch as-is since it's obviously a big improvement over the current state. I'm not too bothered either way whether they screech to a halt or drown themselves - I guess this can be resolved and they can be changed to drown later if people think that'd be better.


- Issue History
Date Modified Username Field Change
2012-05-02 05:14 evilmike New Issue
2012-05-02 07:04 mageykun Note Added: 0017944
2012-05-02 07:07 evilmike Note Added: 0017945
2013-03-01 12:38 mumra File Added: 0001-Fix-strange-interaction-of-boulder-beetles-and-fluid.patch
2013-03-01 12:43 mumra Note Added: 0021211
2013-03-01 14:59 KiloByte Relationship added has duplicate 0006259
2013-03-01 15:21 mumra Note Added: 0021216
2013-03-08 23:20 reid Note Added: 0021313
2013-03-10 22:38 Kate Note Added: 0021347
2013-03-10 22:43 Kate Note Edited: 0021347
2013-03-10 22:43 Kate Status new => resolved
2013-03-10 22:43 Kate Fixed in Branch => 0.12 development branch
2013-03-10 22:43 Kate Resolution open => done
2013-03-10 22:43 Kate Assigned To => Kate


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker