Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005605 [DCSS] Implementables text N/A 2012-04-28 05:18 2012-08-14 22:34
Reporter neil View Status public  
Assigned To MarvinPA
Priority normal Resolution done  
Status closed   Product Branch 0.11 ancient branch
Summary 0005605: Need descriptions for the portal vaults.
Description With the portal_branches merge, the ?/B help now supports all places, not just branches. However, that means that they need descriptions to show up when that branch is selected. There are already descriptions for the entry portals, but not for the places on the other side. Sometimes those existing descriptions would be appropriate descriptions for the level, but other times they are about the passage itself. When it does make sense to use the existing entry feature description, it would be good to provide a replacement description for the feature.

Places that need descriptions: Ziggurat, Labyrinth, Bazaar, Trove, Sewer, Ossuary, Bailey, Ice Cave, Volcano, and Wizlab. Yes, all the Wizlabs share a single entry. I originally thought Pandemonium needed a description, but it has one, just under the name "Pan".

See dat/descript/features.txt for the portal entry feature descriptions, and dat/descript/branches.txt for the branch descriptions:
  * https://gitorious.org/crawl/crawl/blobs/master/crawl-ref/source/dat/descript/features.txt [^]
  * https://gitorious.org/crawl/crawl/blobs/master/crawl-ref/source/dat/descript/branches.txt [^]
Additional Information
Tags No tags attached.
Attached Files

- Relationships
related to 0004573resolvedMarvinPA ?/G and ?/B improvements 

-  Notes
(0017905)
neil (administrator)
2012-04-28 05:34

Add your suggestions as notes to this bug. Patches are overkill for this sort of thing, and only make merging harder.
(0017906)
KiloByte (manager)
2012-04-28 09:41

Languages other than English are fine, too.

At worst, we would translate the other way :)
(0017907)
ion_frigate (reporter)
2012-04-28 10:27
edited on: 2012-04-28 12:29

Wizlab: The laboratory of some wizard, the portal to which has been carelessly left open. Beware, for wizards love to guard their possessions with traps and monsters of their own making!

Bazaar: [can be identical to portal description]

Sewer: [can be identical to portal description]

Ossuary: A small tomb, containing the remains of some distant relatives of the pharaohs. It is undoubtedly home to many traps, and its denizens are unlikely to take kindly to looting.

Trove: Once upon a time, an enterprising thief and wizard, terrified of being caught committing an act of burglary, created a system of portals leading into the secret treasure troves and chambers of the rich. Too scared to loot them himself, he instead charged an extortionate fee for entry to anyone who wanted to rifle through them. A clever artificer, he designed his portals to direct the entrant to the trove most suited to their needs. The items inside this trove are likely to be useful, but beware: the wizard is long dead, and even while alive he never offered a money-back guarantee. [As a sidenote, I'd suggest removing or rewriting the second paragraph of the portal description - it implies that the portals are temporary, which they aren't. In this description, I tried to make it clear that the trove uses acquirement code without flat-out saying so]

Pandemonium: These infinite halls are populated by all manner of demonkind. They contain much in the way of valuable loot and runes, but would-be looters take note: it is far easier to enter than to exit.

Labyrinth: An intricate maze designed by subtle and malicious minds, its exit guarded by a fearsome monster. Many a hapless adventurer has lost his way in the twisted, shifting passages, and starved to death. [Mostly copied from portal description]

Bailey: The castle of some lord. It is undoubtedly protected by physical barriers and well-trained soldiers.

Ziggurat: A series of arenas, each containing greater wealth and even greater danger than the last. Whatever entity created this monstrosity charges a steep price for entry. Beware, for a ziggurat is not a place for the faint of heart: even the bravest and most skilled adventurers have met their ends in one. While a portal to safety will be present on every level, once left, a ziggurat cannot be reentered.

(0017909)
BlackSheep (reporter)
2012-04-28 14:36

Pan had a description on that menu already. Not sure what happened to it.

So I'm thinking these won't fit on the tree view of the dungeon branches suggested here: https://crawl.develz.org/mantis/view.php?id=4573 [^]

I'll shift gears and just make it a PrecisionMenu with mouse support.
(0017910)
neil (administrator)
2012-04-28 16:19

BlackSheep is right... there is a description for Pandemonium; I (and the ?/B menu) missed it because it has the key "Pan" rather than "Pandemonium".
(0017911)
ontoclasm (developer)
2012-04-28 19:04

Ice Cave: A desolate, echo-filled cavern shaped from solid ice. The intricate carvings and statues which once lined its walls have been warped and obscured by centuries of slow melting and refreezing.

Volcano: Built from enormous blocks of obsidian, this sweltering chamber may once have served as a temple to some strange diety, or perhaps the dwelling of a mighty fire giant. The air shimmers with oppressive heat, and the dull roar of the volcano's heart never ceases.
(0017912)
nicolae (reporter)
2012-04-28 22:44
edited on: 2012-04-28 22:46

I posted these in the tavern thread because it was late and I can't read apparently.

Wizlab: In ages past, the most powerful mages -- many of whom you may have heard of -- would frequently find or construct small realms sealed off from the rest of the world, where they could isolate themselves in the pursuit of ever-greater magical knowledge and power. The mages are long gone, but many of their arcane laboratories still exist, filled with the results of their experiments. Those willing to explore these laboratories may find powerful magical treasure left behind, but be warned: the wizards to whom these labs belonged all deserved their mighty reputations.

Bazaar portal: A flickering gateway to a bazaar.

Through the gateway, you can hear the sounds of a travelling bazaar: money changing hands, sellers advertising their wares, and customers haggling in vain. If you're interested in sampling the goods here, you should know that these deals won't last long: you can also hear announcements that the bazaar will soon be closing up and moving on.

Labyrinth: The Labyrinth is a vast and complex maze designed by subtle and malicious minds for reasons long lost to history. Old stories say that the labyrinth was constructed as a prison for a fearsome monster. More recent stories say this beast dwells there still, guarding the labyrinth's sole exit - as well as a hoard of treasure taken from the bodies of the foolish adventurers who got lost inside and starved to death. Take care inside the shifting, twisting passages of this labyrinth, or your own possessions may end up in the beast's treasure pile.

Labyrinth portal: A gateway carved from rock, with intricate convoluted patterns sculpted along its edges. Through the gateway, you can see a few branching hallways of a dark maze. The exquisite carvings of the gateway are broken up by a message, indelicately hacked into the rock, which suggests bringing food. A lot of food.

(0017915)
galehar (administrator)
2012-04-29 14:03

Can someone submit those descriptions to transifex? Thanks!

https://www.transifex.net/projects/p/dcss/resource/branches/l/en/ [^]
(0018243)
Grimm (reporter)
2012-06-06 08:37

All submitted, with modifications.
(0019543)
MarvinPA (developer)
2012-08-14 11:18

These have all since been added.

- Issue History
Date Modified Username Field Change
2012-04-28 05:18 neil New Issue
2012-04-28 05:23 neil Description Updated
2012-04-28 05:25 neil Description Updated
2012-04-28 05:25 neil Relationship added related to 0004573
2012-04-28 05:34 neil Note Added: 0017905
2012-04-28 05:36 neil Description Updated
2012-04-28 09:41 KiloByte Note Added: 0017906
2012-04-28 10:27 ion_frigate Note Added: 0017907
2012-04-28 12:29 ion_frigate Note Edited: 0017907
2012-04-28 12:29 ion_frigate Note Edited: 0017907
2012-04-28 14:36 BlackSheep Note Added: 0017909
2012-04-28 16:19 neil Note Added: 0017910
2012-04-28 16:19 neil Description Updated
2012-04-28 16:20 neil Description Updated
2012-04-28 16:20 neil Description Updated
2012-04-28 19:04 ontoclasm Note Added: 0017911
2012-04-28 22:44 nicolae Note Added: 0017912
2012-04-28 22:46 nicolae Note Edited: 0017912
2012-04-29 14:03 galehar Note Added: 0017915
2012-05-07 02:37 neil Relationship added related to 0005594
2012-05-07 02:37 neil Relationship deleted related to 0005594
2012-06-06 08:37 Grimm Note Added: 0018243
2012-08-14 11:18 MarvinPA Note Added: 0019543
2012-08-14 11:18 MarvinPA Status new => resolved
2012-08-14 11:18 MarvinPA Resolution open => done
2012-08-14 11:18 MarvinPA Assigned To => MarvinPA
2012-08-14 22:34 neil Status resolved => closed


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker