Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005604 [DCSS] Bug Report crash always 2012-04-28 00:13 2015-02-23 16:54
Reporter vickio View Status public  
Assigned To wheals
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0005604: Crash on startup with Mac OS X Lion and full screen tiles mode
Description Mac OS X 10.7.3 on an early 2011 MacBook Pro.

When attempting to start dcss with tiles enabled and tile_full_screen = true in the config file, it crashes with the following error in the terminal:

<Warning>: CGDisplayBaseAddress is obsolete and returning NULL for display 0x7bd8d27f
Failed to set video mode: Error setting OpenGL fullscreen: invalid fullscreen drawable


The screen flashes black for a moment before crashing.

In windowed mode, everything works fine.
Additional Information
Tags No tags attached.
Attached Files

- Relationships
duplicate of 0005535resolvedmumra Crash on mac upon opening. 
related to 0005958resolvedwheals 0.11 versio crashes on Macbook Pro Retina 15" 

-  Notes
(0028557)
wheals (administrator)
2015-02-23 16:54

Seems like it's related to 0007357, which was presumably fixed by the SDL2 upgrade.

- Issue History
Date Modified Username Field Change
2012-04-28 00:13 vickio New Issue
2013-05-26 05:12 mumra Relationship added duplicate of 0005535
2013-05-26 05:24 mumra Relationship added related to 0005958
2015-02-23 16:54 wheals Note Added: 0028557
2015-02-23 16:54 wheals Status new => resolved
2015-02-23 16:54 wheals Fixed in Branch => 0.16 development branch
2015-02-23 16:54 wheals Resolution open => done
2015-02-23 16:54 wheals Assigned To => wheals


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker