Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005590 [DCSS] Bug Report trivial always 2012-04-23 05:38 2013-05-26 22:31
Reporter nicolae View Status public  
Assigned To mumra
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005590: Jumping spiders can jump through iron grates
Description Jumping spiders can jump through iron grates. amethyst in ##crawl-dev said this was probably not intended behavior. I included a quick vault that demonstrates this.
Additional Information
Tags No tags attached.
Attached Files ? file icon jumpbug.des [^] (171 bytes) 2012-04-23 05:38 [Show Content]

- Relationships

-  Notes
(0021878)
mumra (developer)
2013-03-27 08:27

This is because they use Blink Close to jump and this can presumably aim through grates. Grates are generally a bit inconsistent so I'm not sure what the right solution here is:

a) Blink Close shouldn't be able to target through grates
b) Nothing should be able to target through grates
c) Special case Blink Close to not aim through grates for jumping spiders
(0022867)
mumra (developer)
2013-05-26 22:31

Fixed in trunk, I special cased jumping spiders to make sure they have a solid path to the destination (and fixed some other flavour while I was there, e.g. not printing messages about blinking and not creating purple tloc clouds...)

- Issue History
Date Modified Username Field Change
2012-04-23 05:38 nicolae New Issue
2012-04-23 05:38 nicolae File Added: jumpbug.des
2013-03-27 08:27 mumra Note Added: 0021878
2013-05-26 22:31 mumra Note Added: 0022867
2013-05-26 22:31 mumra Status new => resolved
2013-05-26 22:31 mumra Fixed in Branch => 0.13 development branch
2013-05-26 22:31 mumra Resolution open => done
2013-05-26 22:31 mumra Assigned To => mumra


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker