Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005585 [DCSS] Bug Report minor have not tried 2012-04-21 04:52 2013-12-29 14:58
Reporter vortexion View Status public  
Assigned To sgrunt
Priority normal Resolution done  
Status resolved   Product Branch 0.10 ancient branch
Summary 0005585: Teleport trap blocks entrance to the Temple
Description As the summary says, I was blocked from getting to the temple by a teleport trap, it was the spiral clear and metal blocks configuration. I know its possible to get by it, with a blink scroll or by running into it a lot, but it seems like it shouldn't be generated this way. Screenshot attached.
Additional Information
Tags No tags attached.
Attached Files png file icon blocked.png [^] (320,188 bytes) 2012-04-21 04:52

- Relationships
has duplicate 0005636resolvedneil Impossible Level Design 
has duplicate 0007723resolved access to ecumenical temple is blocked in my present game by a teleport trap 

-  Notes
(0017816)
Patashu (reporter)
2012-04-21 06:14

Worth noting that sometimes the altar of the god you want to worship is behind a moat of lava, and the only way is to blink or levitate across. However, it is kind of mean to require blinking for the ENTIRE temple
(0017817)
ion_frigate (reporter)
2012-04-21 08:52
edited on: 2012-04-21 08:53

@Patashu: That's intentional - it's part of the vault design. The teleport trap here, so far as I know, is not, and as you say, is a lot more cruel.

(0017819)
Galefury (updater)
2012-04-21 11:06
edited on: 2012-04-21 11:07

IMO: tough luck, random level generation put you into an interesting situation. It's rare enough to be fine.

If teletraps have limited charges (I don't remember if that actually happened) it's just tedious to deplete it, so in that case making traps not generate in that vault would be better.

(0017845)
minmay (reporter)
2012-04-22 16:27

Patashu: That vault was actually broken by connectivity checks (it would never be placed) and subsequently removed. There are overflow altars that require you to cross lava or trees, though.
(0017967)
neil (administrator)
2012-05-04 17:34
edited on: 2012-05-04 17:35

This should be fixed in trunk (0.11-a0-1677-g09a9b8b); teleport traps are now considered impassable for level generation purposes. I am not 100% certain that would have prevented this particular case, since vaults are kind of funny wrt connectivity checks. It definitely should fix the related 0005636, though.

Please re-open if you encounter this issue again.

(0024049)
thevogonpoet (reporter)
2013-09-18 15:23
edited on: 2013-09-19 10:57

Update: This just occurred to me (vogonpoet on CDO trunk - 0.13-a0-3092-g1832de8 (console)) - my spiral temple vault is protected by a tele trap - No lush choice of temple gods for me. I haz a sad.

Are teleport traps exhaustible? No.

Edit: Haha, on the level below there was a temple stairs mimic, DCSS is trolling me so bad.

(0024069)
KiloByte (manager)
2013-09-23 01:41

I guess not assuming that all vaults are opaque would fix this.
(0024609)
sgrunt (administrator)
2013-12-06 06:01

Turns out traps were generating after level connectivity was checked - which includes accessibility of branch entrances. As of 0.14-a0-1329-g2e84db7 they place before level connectivity is checked, so this should no longer happen.
(0024715)
neil (administrator)
2013-12-12 08:01

Fix applied to stable as well (0.13.1-10-gb041cea)
(0024873)
Eleusis (reporter)
2013-12-29 14:58

Apparently the behaviour is still there: I have the case in my current game in trunk.

- Issue History
Date Modified Username Field Change
2012-04-21 04:52 vortexion New Issue
2012-04-21 04:52 vortexion File Added: blocked.png
2012-04-21 06:14 Patashu Note Added: 0017816
2012-04-21 08:52 ion_frigate Note Added: 0017817
2012-04-21 08:53 ion_frigate Note Edited: 0017817
2012-04-21 11:06 Galefury Note Added: 0017819
2012-04-21 11:07 Galefury Note Edited: 0017819
2012-04-22 16:27 minmay Note Added: 0017845
2012-05-04 15:23 neil Relationship added has duplicate 0005636
2012-05-04 17:34 neil Note Added: 0017967
2012-05-04 17:34 neil Status new => resolved
2012-05-04 17:34 neil Fixed in Branch => 0.11 development branch
2012-05-04 17:34 neil Resolution open => done
2012-05-04 17:34 neil Assigned To => neil
2012-05-04 17:35 neil Note Edited: 0017967
2013-09-18 15:23 thevogonpoet Note Added: 0024049
2013-09-19 10:37 Galefury Status resolved => new
2013-09-19 10:37 Galefury Resolution done => reopened
2013-09-19 10:46 thevogonpoet Issue Monitored: thevogonpoet
2013-09-19 10:57 thevogonpoet Note Edited: 0024049
2013-09-23 01:41 KiloByte Note Added: 0024069
2013-12-06 05:48 sgrunt Relationship added has duplicate 0007723
2013-12-06 06:01 sgrunt Note Added: 0024609
2013-12-06 06:01 sgrunt Assigned To neil => sgrunt
2013-12-06 06:01 sgrunt Status new => resolved
2013-12-06 06:01 sgrunt Resolution reopened => done
2013-12-12 08:01 neil Note Added: 0024715
2013-12-12 08:01 neil Fixed in Branch 0.11 ancient branch => 0.13 stable branch
2013-12-29 14:58 Eleusis Note Added: 0024873


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker