Viewing Issue Simple Details Jump to Notes ] Wiki ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0005554 [DCSS] Bug Report crash always 2012-04-11 14:09 2015-03-19 22:43
Reporter KiloByte View Status public  
Assigned To neil
Priority normal Resolution done  
Status resolved   Product Branch 0.11 ancient branch
Summary 0005554: reproducible crash in line_reader
Description Change your terminal width to 80 columns (80x30 and 80x24 crash, rest untested). Define a new macro. Repeatedly paste in the following:

\{9}\{9}\{9}\{9}\{9}\{9}\{9}
Additional Information
Tags No tags attached.
Attached Files

- Relationships

-  Notes
(0017714)
edlothiol (developer)
2012-04-11 15:09

I think it happens with any input when it's too long to fit into the message area (i.e. needs more lines than there are available).
(0017715)
neil (administrator)
2012-04-11 15:39
edited on: 2012-04-11 15:54

I looked into fixing this, thinking I could just cut off the first N lines if the first line would have y = (1 - N). However, that just leads to a different crash, when the last few lines go off the end of the screen. The number of lines needed is estimated by ((start.x + nchars - 1) / wrapcol), but wordwrap_line might produce more lines (up to twice as many) because it tries not to break words.

A solution would be to character-wrap rather than word-wrap; or to restructure the code so that the lines are wrapped before trying to guess where the cursor should go. The former still has problems with full-width CJK characters.

(0028539)
neil (administrator)
2015-02-20 21:23

Probably simpler to fix now that it's back to column- rather than word-wrapping (0.16-a0-4058-ga3e9557).
(0028673)
neil (administrator)
2015-03-19 22:43

Should be fixed, finally, in 0.17-a0-117-g31482b3. There are still some display bugs (when the prompt scrolls off because of the size of the input line, it won't come back even if you clear the input line), but the crashes seem to be fixed.

- Issue History
Date Modified Username Field Change
2012-04-11 14:09 KiloByte New Issue
2012-04-11 15:09 edlothiol Note Added: 0017714
2012-04-11 15:39 neil Note Added: 0017715
2012-04-11 15:39 neil Note Edited: 0017715
2012-04-11 15:49 neil Note Edited: 0017715
2012-04-11 15:54 neil Note Edited: 0017715
2015-02-20 21:23 neil Note Added: 0028539
2015-03-19 22:43 neil Note Added: 0028673
2015-03-19 22:43 neil Status new => resolved
2015-03-19 22:43 neil Fixed in Branch => 0.17 development branch
2015-03-19 22:43 neil Resolution open => done
2015-03-19 22:43 neil Assigned To => neil


Mantis 1.1.8[^]
Copyright © 2000 - 2009 Mantis Group
Powered by Mantis Bugtracker